aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 14:26:44 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 14:30:49 +0000
commit2ebfb9d9ed7554180c3c077b14291a1853f8e2ef (patch)
treee1ca4362e7a98346aabc5143c6391afa2ddda43c /meta/recipes-sato/puzzles
parent6e2b53f47da0e97271fb51b281d24da1e1d549cc (diff)
downloadopenembedded-core-contrib-2ebfb9d9ed7554180c3c077b14291a1853f8e2ef.tar.gz
puzzles: Ensure to link against libm for math functions
Without this we can see failures like: | make: *** [samegame] Error 1 | /media/build1/poky/build/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.6.3/ld: inertia.o: undefined reference to symbol 'sqrt@@GLIBC_2.0' | /media/build1/poky/build/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.6.3/ld: note: 'sqrt@@GLIBC_2.0' is defined in DSO /media/build1/poky/build/tmp/sysroots/qemux86/lib/libm.so.6 so try adding it to the linker command line | /media/build1/poky/build/tmp/sysroots/qemux86/lib/libm.so.6: could not read symbols: Invalid operation | collect2: ld returned 1 exit status | make: *** [inertia] Error 1 Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/puzzles')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r9306.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9306.bb b/meta/recipes-sato/puzzles/puzzles_r9306.bb
index c3849309ad..d9b8e3e405 100644
--- a/meta/recipes-sato/puzzles/puzzles_r9306.bb
+++ b/meta/recipes-sato/puzzles/puzzles_r9306.bb
@@ -2,7 +2,7 @@ DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
DEPENDS = "gtk+ libxt"
-PR = "r0"
+PR = "r1"
MOD_PV = "${@d.getVar('PV',1)[1:]}"
LICENSE = "MIT"
@@ -23,6 +23,7 @@ do_configure () {
do_compile_prepend = " \
export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
+ export XLFLAGS=-lm \
export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*"