aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-10 19:17:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:11 +0100
commit1722ce23075a00e111145cad6daa2ef87ba391fe (patch)
tree68aba0e232beca1f632d13b3ee798b48af9298c8 /meta/recipes-sato/puzzles
parent777080af697d35b3f983465d6a094f4171e57e56 (diff)
downloadopenembedded-core-contrib-1722ce23075a00e111145cad6daa2ef87ba391fe.tar.gz
libowl/settings-daemon/libnotify: add x11 to REQUIRED_DISTRO_FEATURES
The libowl, settings-daemon and libnotify requires gdk/gdkx.h which is provided by gtk when x11 in DISTRO_FEATURES, so add x11 to REQUIRED_DISTRO_FEATURES. The leafpad, settings-daemon and oh-puzzles requires libowl or settings-daemon, so add xx to REQUIRED_DISTRO_FEATURES for them too. The leafpad can't be built without libowl, so depends in directly rather than use DEPENDS_append_poky. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-sato/puzzles')
-rw-r--r--meta/recipes-sato/puzzles/oh-puzzles_git.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-sato/puzzles/oh-puzzles_git.bb b/meta/recipes-sato/puzzles/oh-puzzles_git.bb
index bd762e9315..36cd2cc7a2 100644
--- a/meta/recipes-sato/puzzles/oh-puzzles_git.bb
+++ b/meta/recipes-sato/puzzles/oh-puzzles_git.bb
@@ -9,7 +9,12 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=f56ec6772dd1c7c367067bbea8ea1675 \
SECTION = "x11"
DEPENDS = "gtk+ gconf intltool-native librsvg"
-DEPENDS_append_poky = " libowl"
+
+# libowl requires x11 in DISTRO_FEATURES
+DEPENDS_append_poky = " ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libowl', '', d)}"
+
+# Requires gdk/gdkx.h which is provided by gtk when x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
SRCREV = "92f1a20e4b72eed7a35b00984d9793b51dc2fb3b"
PV = "0.2+git${SRCPV}"
@@ -20,7 +25,7 @@ SRC_URI_append_poky = " file://oh-puzzles-owl-menu.patch;striplevel=0 "
S = "${WORKDIR}/git"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
bindir = "/usr/games"