summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-04 15:38:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-16 12:11:24 +0000
commit0dc44aeb49a8a254ca3345870b62282b04d4b61f (patch)
tree85bff43c7a3fa3072dd352889c795eba985ddcbc /meta/recipes-sato/puzzles
parent08fb2a4c2eaabdb2944cefefed51d1b95aedbde1 (diff)
downloadopenembedded-core-contrib-0dc44aeb49a8a254ca3345870b62282b04d4b61f.tar.gz
puzzles: update to current commit
gtk+3 support has been added upstream, so add an option for that. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-sato/puzzles')
-rw-r--r--meta/recipes-sato/puzzles/files/fix-compiling-failure-with-option-g-O.patch9
-rw-r--r--meta/recipes-sato/puzzles/puzzles_git.bb8
2 files changed, 6 insertions, 11 deletions
diff --git a/meta/recipes-sato/puzzles/files/fix-compiling-failure-with-option-g-O.patch b/meta/recipes-sato/puzzles/files/fix-compiling-failure-with-option-g-O.patch
index d246feeb09..c134acde2f 100644
--- a/meta/recipes-sato/puzzles/files/fix-compiling-failure-with-option-g-O.patch
+++ b/meta/recipes-sato/puzzles/files/fix-compiling-failure-with-option-g-O.patch
@@ -29,15 +29,6 @@ diff --git a/gtk.c b/gtk.c
index a2eba2c..c54bf63 100644
--- a/gtk.c
+++ b/gtk.c
-@@ -381,7 +381,7 @@ static void clear_backing_store(frontend *fe)
-
- static void setup_backing_store(frontend *fe)
- {
-- cairo_t *cr;
-+ cairo_t *cr = NULL;
- int i;
-
- fe->pixmap = gdk_pixmap_new(fe->area->window, fe->pw, fe->ph, -1);
@@ -2481,7 +2481,7 @@ char *fgetline(FILE *fp)
int main(int argc, char **argv)
{
diff --git a/meta/recipes-sato/puzzles/puzzles_git.bb b/meta/recipes-sato/puzzles/puzzles_git.bb
index 56fae88d19..1e3bac7458 100644
--- a/meta/recipes-sato/puzzles/puzzles_git.bb
+++ b/meta/recipes-sato/puzzles/puzzles_git.bb
@@ -1,7 +1,7 @@
SUMMARY = "Simon Tatham's Portable Puzzle Collection"
HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
-DEPENDS = "gtk+ libxt"
+DEPENDS = "libxt"
# The libxt requires x11 in DISTRO_FEATURES
REQUIRED_DISTRO_FEATURES = "x11"
@@ -13,7 +13,7 @@ SRC_URI = "git://git.tartarus.org/simon/puzzles.git \
file://fix-compiling-failure-with-option-g-O.patch \
file://0001-Use-labs-instead-of-abs.patch \
"
-SRCREV = "c296301a06ce49b87c954c9d15452521dfeddf1a"
+SRCREV = "346584bf6e38232be8773c24fd7dedcbd7b3d9ed"
PE = "1"
PV = "0.0+git${SRCPV}"
@@ -21,6 +21,10 @@ S = "${WORKDIR}/git"
inherit autotools-brokensep distro_features_check
+PACKAGECONFIG ??= "gtk2"
+PACKAGECONFIG[gtk2] = "--with-gtk=2,,gtk+,"
+PACKAGECONFIG[gtk3] = "--with-gtk=3,,gtk+3,"
+
do_configure_prepend () {
./mkfiles.pl
}