aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-10-10 15:25:50 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-14 12:53:32 +0100
commit83ea07f8fb635a01dfe976ba0e518df282eef30d (patch)
treeb25769ef9803ecaadf07c85f1656beaf22963a80 /meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb
parent971f593cd2454449f0997c948396107ebf85da41 (diff)
downloadopenembedded-core-contrib-83ea07f8fb635a01dfe976ba0e518df282eef30d.tar.gz
pcmanfm: Upgrade to 0.9.9
Update owl-window-menu.patch. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb')
-rw-r--r--meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb b/meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb
new file mode 100644
index 0000000000..af283f6cf8
--- /dev/null
+++ b/meta/recipes-sato/pcmanfm/pcmanfm_0.9.9.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Fast lightweight tabbed filemanager"
+HOMEPAGE = "http://pcmanfm.sourceforge.net/"
+BUGTRACKER = ""
+
+LICENSE = "GPLv2 & GPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ file://src/pcmanfm.h;endline=22;md5=417b3855771a3a87f8ad753d994491f0 \
+ file://src/gseal-gtk-compat.h;endline=21;md5=46922c8691f58d124f9420fe16149ce2"
+
+SECTION = "x11"
+DEPENDS = "gtk+ startup-notification libfm"
+DEPENDS_append_poky = " libowl"
+
+PR = "r0"
+
+COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|mips.*|powerpc.*)-(linux|freebsd.*)'
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.gz \
+ file://gnome-fs-directory.png \
+ file://gnome-fs-regular.png \
+ file://gnome-mime-text-plain.png \
+ file://emblem-symbolic-link.png \
+ file://cross-compile-fix.patch"
+
+SRC_URI_append_poky = " file://owl-window-menu.patch"
+
+SRC_URI[md5sum] = "f31ed6defb600f7046a456220d8efa3a"
+SRC_URI[sha256sum] = "bc48af4ade638b47e4207cc274f6e38c2bd3786a811d20da47c3df9907c6fb6c"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}/${datadir}
+ install -d ${D}/${datadir}/pixmaps/
+
+ install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
+}