aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-07-25 11:10:17 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-12 17:16:59 +0100
commitbafaaad264fe3e745c714951ddcf2784d33b755a (patch)
treecb475094cdc455d46cf0148f0ddb7046c9407bd7 /meta/recipes-rt
parent92aa6a587f4fabfadbebdb7ae24306d36f43910a (diff)
downloadopenembedded-core-contrib-bafaaad264fe3e745c714951ddcf2784d33b755a.tar.gz
Move meta-rt recipes to oe-core (meta)
Keeping the rt recipes in their own layer has led to maintenance issues, particularly with the linux-yocto-rt recipes. As these kernel types are part of the same linux-yocto source repository, it seems reasonable to include the rt kernel recipes alongside the standard recipes. A new recipes-rt directory for the other recipes provides adequate separation and eliminates the need for a separate layer. As there is no meta-rt/conf/layer.conf to force the kernel, users must now specify the rt kernel in their local.conf or in the machine.conf: PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-rt" The merging of the rt recipes into the core also eliminates complications with multiple layer dependencies for new BSP layers. Having to either separate RT BSPs from standard BSPs or force users to add meta-rt to bblayers even when not building an RT BSP (because the RT BSPs in the same layer would fail to parse without it) was sub-optimal at best. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta/recipes-rt')
-rw-r--r--meta/recipes-rt/images/core-image-rt-sdk.bb15
-rw-r--r--meta/recipes-rt/images/core-image-rt.bb12
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_0.73.bb22
3 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-rt/images/core-image-rt-sdk.bb b/meta/recipes-rt/images/core-image-rt-sdk.bb
new file mode 100644
index 0000000000..6e983433aa
--- /dev/null
+++ b/meta/recipes-rt/images/core-image-rt-sdk.bb
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2011 Intel Corporation.
+#
+
+DESCRIPTION = "Real-Time Linux Image with SDK support"
+DEPENDS = "linux-yocto-rt"
+
+require recipes-core/images/core-image-minimal.bb
+
+IMAGE_FEATURES += "dev-pkgs tools-sdk"
+EXTRA_IMAGE_FEATURES += "tools-debug tools-profile tools-testapps debug-tweaks"
+
+IMAGE_INSTALL += "rt-tests"
+
+LICENSE = "MIT"
diff --git a/meta/recipes-rt/images/core-image-rt.bb b/meta/recipes-rt/images/core-image-rt.bb
new file mode 100644
index 0000000000..e11f159f7a
--- /dev/null
+++ b/meta/recipes-rt/images/core-image-rt.bb
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 Intel Corporation.
+#
+
+DESCRIPTION = "Real-Time Linux Image"
+DEPENDS = "linux-yocto-rt"
+
+require recipes-core/images/core-image-minimal.bb
+
+IMAGE_INSTALL += "rt-tests"
+
+LICENSE = "MIT"
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.73.bb b/meta/recipes-rt/rt-tests/rt-tests_0.73.bb
new file mode 100644
index 0000000000..6334bcdeef
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_0.73.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Real-Time preemption testcases"
+HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
+SECTION = "tests"
+DEPENDS = "linux-libc-headers eglibc"
+LICENSE = "GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=ce162fe491d19d2ec67dff6dbc938d50 \
+ file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
+SRCREV = v0.73
+PV = "git${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/clrkwllms/rt-tests.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+CFLAGS += "-I${S}/src/include -D_GNU_SOURCE -Wall -Wno-nonnull"
+
+do_install() {
+ oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
+ INCLUDEDIR=${includedir}
+}