aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-11-23 13:22:02 +0000
committerJoshua Lock <joshua.g.lock@intel.com>2016-12-05 15:36:27 +0000
commit65250a5537da220dff662269cb81d086b66c2ace (patch)
treec0b1fc6c9e8471346c416b964eff583f51d26589 /meta/recipes-rt
parent11063a01d4511b2688ea7ba2d7359e4e07328c66 (diff)
downloadopenembedded-core-contrib-65250a5537da220dff662269cb81d086b66c2ace.tar.gz
meta: remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta/recipes-rt')
-rw-r--r--meta/recipes-rt/images/core-image-rt-sdk.bb2
-rw-r--r--meta/recipes-rt/images/core-image-rt.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-rt/images/core-image-rt-sdk.bb b/meta/recipes-rt/images/core-image-rt-sdk.bb
index 7ddf671bca..7c1e5bf261 100644
--- a/meta/recipes-rt/images/core-image-rt-sdk.bb
+++ b/meta/recipes-rt/images/core-image-rt-sdk.bb
@@ -4,7 +4,7 @@ require recipes-core/images/core-image-minimal.bb
# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
# to build multiple virtual/kernel providers.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-rt":
+ if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
diff --git a/meta/recipes-rt/images/core-image-rt.bb b/meta/recipes-rt/images/core-image-rt.bb
index 9c86f25335..d8bb04aa1e 100644
--- a/meta/recipes-rt/images/core-image-rt.bb
+++ b/meta/recipes-rt/images/core-image-rt.bb
@@ -4,7 +4,7 @@ require recipes-core/images/core-image-minimal.bb
# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
# to build multiple virtual/kernel providers.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-rt":
+ if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}