aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-08-04 14:14:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-20 22:31:13 +0000
commit3328211afdef8ffb00dd4dff1143959d5412b075 (patch)
tree4903b2b0ed8c09605baf9c546eac47fa0617d83a /meta/recipes-rt
parentc47b54aeae5daabb458d6f7118a16257021c1822 (diff)
downloadopenembedded-core-contrib-3328211afdef8ffb00dd4dff1143959d5412b075.tar.gz
python: fix RDEPENDS on several recipes, due to non-existent packages
The packaging has been altered slightly so ensure the dependencies are all still valid. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-rt')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb2
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_1.1.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
index 012b2dd0a7..5f61c4ecdd 100644
--- a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
@@ -22,5 +22,5 @@ do_install() {
}
FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
-RDEPENDS_${PN} = "python3 python3-subprocess python3-textutils"
+RDEPENDS_${PN} = "python3-core "
RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"
diff --git a/meta/recipes-rt/rt-tests/rt-tests_1.1.bb b/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
index 4336c50d63..496f04fdba 100644
--- a/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
+++ b/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
@@ -26,6 +26,6 @@ do_install_ptest() {
cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
}
-RDEPENDS_${PN}-ptest += " stress python3 python3-subprocess python3-multiprocessing python3-datetime python3-re python3-lang python3-misc"
+RDEPENDS_${PN}-ptest += " stress python3 python3-multiprocessing python3-datetime python3-misc"
FILES_${PN} += "${prefix}/src/backfire"