summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-03-15 14:51:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-16 10:55:27 +0000
commit04099ff7c1177b0d676591f3a5db86158738461f (patch)
treed3403e07f01fa79cf498360dd6e090c9c16475a4 /meta/recipes-rt
parent1f591ae09a860ae8471c3f9c8f40a4e34f596baf (diff)
downloadopenembedded-core-contrib-04099ff7c1177b0d676591f3a5db86158738461f.tar.gz
rt-tests: Add src/backfire to FILES_${PN}
Fixes [YOCTO #2114] The rt-tests recipe was issuing the following WARNINGs: WARNING: For recipe rt-tests, the following files/directories were installed but not shipped in any package: WARNING: /usr/src WARNING: /usr/src/backfire WARNING: /usr/src/backfire/backfire.c WARNING: /usr/src/backfire/Makefile Add ${prefix}/src/backfire to FILES_${PN} to include these files in the package. These depend on the target kernel and are meant to be able to be rebuilt as needed. Ideally we would also build this module and include it with rt-tests or the linux-yocto-rt kernel. For now, conform with the intent of the rt-tests Makefile and avoid the WARNINGs. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta/recipes-rt')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_0.83.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.83.bb b/meta/recipes-rt/rt-tests/rt-tests_0.83.bb
index 78d51b3f99..64250278bb 100644
--- a/meta/recipes-rt/rt-tests/rt-tests_0.83.bb
+++ b/meta/recipes-rt/rt-tests/rt-tests_0.83.bb
@@ -11,6 +11,7 @@ SRCREV = "5f1e84f8b015df3ff950056494134eca3f640d70"
# git -> 0.83 needs a PE bump
PE = "1"
+PR = "r1"
SRC_URI = "git://github.com/clrkwllms/rt-tests.git"
@@ -25,3 +26,5 @@ do_install() {
oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
INCLUDEDIR=${includedir}
}
+
+FILES_${PN} += "${prefix}/src/backfire"