aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-07-25 21:03:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-26 08:56:32 +0100
commit87678bbdc84f4e0061a978f570af27c7979a4ddb (patch)
tree3c08e743ae7179f55068e67f22c9b397c1d9183e /meta/recipes-rt
parent3ec9a621d000037a1657c0b18b5bdf3fb405a56c (diff)
downloadopenembedded-core-contrib-87678bbdc84f4e0061a978f570af27c7979a4ddb.tar.gz
rt-tests: rationalise compiler flags
This recipe uses some convoluted methods to ensure the build is using the right flags but they don't appear to be needed anymore. No need to prepend HOST_CC_ARCH/TOOLCHAIN_OPTIONS via CFLAGS as the Makefile picks up CC from the environment and that includes these options. No need to append the default CFLAGS as their special options are actually in CPPFLAGS. (From OE-Core rev: 2230e5f7bf7e6dc747ada74477d5a72905d8d80b) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests.inc3
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_2.0.bb4
2 files changed, 1 insertions, 6 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests.inc b/meta/recipes-rt/rt-tests/rt-tests.inc
index fd6500bfad..d832828e97 100644
--- a/meta/recipes-rt/rt-tests/rt-tests.inc
+++ b/meta/recipes-rt/rt-tests/rt-tests.inc
@@ -5,8 +5,5 @@ SRC_URI = "git://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git"
S = "${WORKDIR}/git"
-# need to append rt-tests' default CFLAGS to ours
-CFLAGS += "-I${S}/src/include -D_GNU_SOURCE -Wall -Wno-nonnull"
-
# calling 'uname -m' is broken on crossbuilds
EXTRA_OEMAKE = "NUMA=0"
diff --git a/meta/recipes-rt/rt-tests/rt-tests_2.0.bb b/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
index 83869b89b8..4336c50d63 100644
--- a/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
+++ b/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
@@ -15,9 +15,7 @@ SRC_URI += " \
file://rt_bmark.py \
"
# Do not install hwlatdetect
-EXTRA_OEMAKE += "PYLIB='' CROSS_COMPILE=${TARGET_PREFIX}"
-
-CFLAGS_prepend = "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}"
+EXTRA_OEMAKE += "PYLIB=''"
do_install() {
oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \