aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-03 10:57:13 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:49 +0000
commit8d83c6ad78e1f965a55c0d3f430bad2781a3eb33 (patch)
tree004baae2b341cbc139b13fa7636574c085baf6d9 /meta/recipes-rt/rt-tests
parentc3dc346d44c8c5485b3eb1a97f32ba2ed2e76ece (diff)
downloadopenembedded-core-contrib-8d83c6ad78e1f965a55c0d3f430bad2781a3eb33.tar.gz
rt-tests: Fix build with non-gcc compilers
Makery hard sets CC to be some form of gcc, make it set only if CC variable is absent in environment. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-rt/rt-tests')
-rw-r--r--meta/recipes-rt/rt-tests/files/0001-Makefile-Set-CC-AR-variable-only-if-it-doesn-t-have-.patch30
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_0.96.bb3
2 files changed, 32 insertions, 1 deletions
diff --git a/meta/recipes-rt/rt-tests/files/0001-Makefile-Set-CC-AR-variable-only-if-it-doesn-t-have-.patch b/meta/recipes-rt/rt-tests/files/0001-Makefile-Set-CC-AR-variable-only-if-it-doesn-t-have-.patch
new file mode 100644
index 0000000000..00fcc7d722
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/files/0001-Makefile-Set-CC-AR-variable-only-if-it-doesn-t-have-.patch
@@ -0,0 +1,30 @@
+From 9640dde4241e1314b8e8ea35b0c8dab0b30ae51f Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 3 Jan 2016 10:50:56 -0800
+Subject: [PATCH] Makefile: Set CC/AR variable only if it doesn't have a value
+
+This helps it compile with clang or any other compilers besides gcc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1e4b7d1..2c2d396 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 0.96
+-CC=$(CROSS_COMPILE)gcc
+-AR=$(CROSS_COMPILE)ar
++CC?=$(CROSS_COMPILE)gcc
++AR?=$(CROSS_COMPILE)ar
+
+ OBJDIR = bld
+
+--
+2.6.4
+
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.96.bb b/meta/recipes-rt/rt-tests/rt-tests_0.96.bb
index 7d703925a8..2f96fea9b5 100644
--- a/meta/recipes-rt/rt-tests/rt-tests_0.96.bb
+++ b/meta/recipes-rt/rt-tests/rt-tests_0.96.bb
@@ -10,7 +10,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
require rt-tests.inc
inherit ptest
-SRC_URI += "file://run-ptest \
+SRC_URI += "file://0001-Makefile-Set-CC-AR-variable-only-if-it-doesn-t-have-.patch \
+ file://run-ptest \
file://rt_bmark.py \
"
# Do not install hwlatdetect