summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_0.92.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2015-06-16 23:25:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-23 11:38:14 +0100
commit9c0db9cedc05e80f6ddef29ec3eaeaa1063e51c7 (patch)
treeebb009aaf7f55562a82f0ee768d2ec27ec54bd6e /meta/recipes-rt/rt-tests/hwlatdetect_0.92.bb
parent8152bcadba8581f75822b75e13c2a43dd6464cd3 (diff)
downloadopenembedded-core-contrib-9c0db9cedc05e80f6ddef29ec3eaeaa1063e51c7.tar.gz
rt-tests: bump version to v0.92
Version upgrade to v0.92 Rebased below listed patch to newer source code: added-missing-dependencies.patch Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_0.92.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.92.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.92.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.92.bb
new file mode 100644
index 0000000000..8319eb987a
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.92.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Hardware latency detector"
+DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
+HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
+SECTION = "tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+require rt-tests.inc
+
+EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
+
+do_compile() {
+ oe_runmake hwlatdetect
+}
+
+do_install() {
+ oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
+ MANDIR=${mandir} INCLUDEDIR=${includedir}
+}
+
+FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
+RDEPENDS_${PN} = "python python-subprocess python-textutils"
+RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"