aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-22 17:43:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-31 10:21:04 -0700
commit81813c0e322dc04ce4b069117188d8a54dfddb8c (patch)
tree3363bac6dcdcdad14ba58efcea39529436cdf72d /meta/recipes-qt
parentf01f0b8aed25af889f48fe1afff96feb3d9ed120 (diff)
downloadopenembedded-core-contrib-81813c0e322dc04ce4b069117188d8a54dfddb8c.tar.gz
nativesdk: Switch to using nativesdk as a prefix, not a suffix
As discussed on the mailing lists, using a suffix to package names is hard and has lead to many recipes having to do PKGSUFFIX games. Its looking extremely hard to scale nativesdk much further without hacking many recipes. By comparison, using a prefix like multilib does works much better and doesn't involve "hacking" as many recipes. This change converts nativesdk to use a prefix using the existing multilib infrastructure. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-qt')
-rw-r--r--meta/recipes-qt/meta/meta-toolchain-qte.bb2
-rw-r--r--meta/recipes-qt/qt4/files/qt-dbus-const.patch2
-rw-r--r--meta/recipes-qt/qt4/nativesdk-qt4-tools_4.8.1.bb (renamed from meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.1.bb)0
-rw-r--r--meta/recipes-qt/tasks/nativesdk-task-qte-toolchain-host.bb7
-rw-r--r--meta/recipes-qt/tasks/task-qte-toolchain-host-nativesdk.bb7
5 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-qt/meta/meta-toolchain-qte.bb b/meta/recipes-qt/meta/meta-toolchain-qte.bb
index 735ccd10ab..116db914a1 100644
--- a/meta/recipes-qt/meta/meta-toolchain-qte.bb
+++ b/meta/recipes-qt/meta/meta-toolchain-qte.bb
@@ -1,6 +1,6 @@
# Qt Embedded toolchain
PR = "r5"
-TOOLCHAIN_HOST_TASK = "task-qte-toolchain-host-nativesdk task-cross-canadian-${TRANSLATED_TARGET_ARCH}"
+TOOLCHAIN_HOST_TASK = "nativesdk-task-qte-toolchain-host task-cross-canadian-${TRANSLATED_TARGET_ARCH}"
TOOLCHAIN_TARGET_TASK = "task-qte-toolchain-target"
TOOLCHAIN_OUTPUTNAME = "${SDK_NAME}-toolchain-qte-${DISTRO_VERSION}"
diff --git a/meta/recipes-qt/qt4/files/qt-dbus-const.patch b/meta/recipes-qt/qt4/files/qt-dbus-const.patch
index f3de77e3e6..6ee402fdc1 100644
--- a/meta/recipes-qt/qt4/files/qt-dbus-const.patch
+++ b/meta/recipes-qt/qt4/files/qt-dbus-const.patch
@@ -1,4 +1,4 @@
-Remove "const" usage that causes compile failure building qt4-tools-nativesdk
+Remove "const" usage that causes compile failure building nativesdk-qt4-tools
Upstream-Status: Denied [possible retry]
diff --git a/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.1.bb b/meta/recipes-qt/qt4/nativesdk-qt4-tools_4.8.1.bb
index e17a8ad808..e17a8ad808 100644
--- a/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.1.bb
+++ b/meta/recipes-qt/qt4/nativesdk-qt4-tools_4.8.1.bb
diff --git a/meta/recipes-qt/tasks/nativesdk-task-qte-toolchain-host.bb b/meta/recipes-qt/tasks/nativesdk-task-qte-toolchain-host.bb
new file mode 100644
index 0000000000..5098d11388
--- /dev/null
+++ b/meta/recipes-qt/tasks/nativesdk-task-qte-toolchain-host.bb
@@ -0,0 +1,7 @@
+require recipes-core/tasks/nativesdk-task-sdk-host.bb
+
+DESCRIPTION = "Host packages for Qt Embedded SDK"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+RDEPENDS_${PN} += "nativesdk-qt4-tools"
diff --git a/meta/recipes-qt/tasks/task-qte-toolchain-host-nativesdk.bb b/meta/recipes-qt/tasks/task-qte-toolchain-host-nativesdk.bb
deleted file mode 100644
index cfa45ef939..0000000000
--- a/meta/recipes-qt/tasks/task-qte-toolchain-host-nativesdk.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require recipes-core/tasks/task-sdk-host-nativesdk.bb
-
-DESCRIPTION = "Host packages for Qt Embedded SDK"
-LICENSE = "MIT"
-ALLOW_EMPTY = "1"
-
-RDEPENDS_${PN} += "qt4-tools-nativesdk"