summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt5/qtwebkit-examples_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-04-25 21:03:54 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-24 11:13:28 +0100
commitc44fc9b620f762ce68441f834e1a157288a488e6 (patch)
tree6d6c8d22c68c02b30e5f9240fa8fe84015e3586d /meta/recipes-qt/qt5/qtwebkit-examples_git.bb
parentc639a01c7a3ecf1a127fa43fa780fd6328c1367e (diff)
downloadopenembedded-core-contrib-c44fc9b620f762ce68441f834e1a157288a488e6.tar.gz
qt5: import recipes which often reproduce Yocto #12434 from meta-qt5
* just temporary to make it easier to reproduce, import big part of meta-qt5 * qtquickcontrols-5.9.5+gitAUTOINC+75e9561d4f-r0 do_package_qa: QA Issue: qtquickcontrols: /qtquickcontrols-qmlplugins/usr/lib/qml/QtQuick/Controls/Styles/Base/TreeViewStyle.qml is owned by uid 1101, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] * to reproduce this you can try to use something like this: export COMP=qtquickcontrols; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-qt/qt5/qtwebkit-examples_git.bb')
-rw-r--r--meta/recipes-qt/qt5/qtwebkit-examples_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt5/qtwebkit-examples_git.bb b/meta/recipes-qt/qt5/qtwebkit-examples_git.bb
new file mode 100644
index 0000000000..114fab7a7d
--- /dev/null
+++ b/meta/recipes-qt/qt5/qtwebkit-examples_git.bb
@@ -0,0 +1,22 @@
+require qt5.inc
+require qt5-git.inc
+
+LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.GPLv2;md5=05832301944453ec79e40ba3c3cfceec \
+ file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \
+ file://LICENSE.LGPLv3;md5=b8c75190712063cde04e1f41b6fdad98 \
+ file://LICENSE.GPLv3;md5=40f9bf30e783ddc201497165dfb32afb \
+ file://examples/webkitwidgets/scroller/wheel/main.cpp;endline=39;md5=b0739af76072fbe303dc04b6941e054f \
+ file://examples/webkitwidgets/imageanalyzer/imageanalyzer.cpp;endline=39;md5=b0739af76072fbe303dc04b6941e054f \
+"
+
+PACKAGECONFIG ?= "examples"
+
+DEPENDS += "qtwebkit qtxmlpatterns"
+RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins"
+RDEPENDS_${PN}-examples += "${@bb.utils.contains('PACKAGECONFIG_OPENSSL', 'openssl', 'ca-certificates', '', d)}"
+
+QT_MODULE_BRANCH = "5.9"
+
+SRCREV = "a24c780b60d7d8bc00c4a48042cf7f32db777d55"