summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt5/qtscxml_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-04-25 21:03:54 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-24 11:13:28 +0100
commitc44fc9b620f762ce68441f834e1a157288a488e6 (patch)
tree6d6c8d22c68c02b30e5f9240fa8fe84015e3586d /meta/recipes-qt/qt5/qtscxml_git.bb
parentc639a01c7a3ecf1a127fa43fa780fd6328c1367e (diff)
downloadopenembedded-core-contrib-c44fc9b620f762ce68441f834e1a157288a488e6.tar.gz
qt5: import recipes which often reproduce Yocto #12434 from meta-qt5
* just temporary to make it easier to reproduce, import big part of meta-qt5 * qtquickcontrols-5.9.5+gitAUTOINC+75e9561d4f-r0 do_package_qa: QA Issue: qtquickcontrols: /qtquickcontrols-qmlplugins/usr/lib/qml/QtQuick/Controls/Styles/Base/TreeViewStyle.qml is owned by uid 1101, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] * to reproduce this you can try to use something like this: export COMP=qtquickcontrols; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-qt/qt5/qtscxml_git.bb')
-rw-r--r--meta/recipes-qt/qt5/qtscxml_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt5/qtscxml_git.bb b/meta/recipes-qt/qt5/qtscxml_git.bb
new file mode 100644
index 0000000000..feb333fe20
--- /dev/null
+++ b/meta/recipes-qt/qt5/qtscxml_git.bb
@@ -0,0 +1,24 @@
+LICENSE = "LGPL-3.0 & BSD & GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
+ file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
+ file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
+"
+
+require qt5.inc
+require qt5-git.inc
+
+DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
+
+SRCREV = "d9b2f8c56d162c108d5427769a8e496dd7a3b62e"
+
+# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.10
+# 5.10.meta-qt5.2
+SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch"
+
+do_install_append_class-nativesdk() {
+ # qml files not needed in nativesdk
+ rm -rf ${D}${OE_QMAKE_PATH_QML}
+}
+
+BBCLASSEXTEND =+ "native nativesdk"