aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-02-08 17:00:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-28 12:14:49 +0000
commit4306606489a2d922595d4c86a21c496bbd8a607e (patch)
treeac51f2fb9e058cfd67af16eff29484dde8e73d72 /meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb
parentf29bb5b2a99ecef46e5570bf3336e9680c0b6705 (diff)
downloadopenembedded-core-contrib-4306606489a2d922595d4c86a21c496bbd8a607e.tar.gz
qt4: build qmake for the target
qmake was not being built at all (since we had the host version from qt4-native) and the default is to build for the host machine within configure. With a minor hack we can build qmake for the target as well, which is useful if you want to build Qt 4 software on an actual device. This is now installed as part of the tools package (together with uic, moc etc.) Additionally, add an environment setup script (installed in /usr/share/qt4/environment-setup or /usr/share/qtopia/environment-setup for the embedded version) as part of the mkspecs package since the mkspecs will not work without the paths set up by this script. The code to create this script was adapted from the qmake2 recipe in meta-oe. Also move do_compile() from qt-${PV}.inc up to qt4.inc as both versions have the exact same content. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb')
-rw-r--r--meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb b/meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb
index 9b66d0327c..a1fcafb0a0 100644
--- a/meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb
+++ b/meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb
@@ -1,7 +1,7 @@
require qt-${PV}.inc
require qt4-embedded.inc
-PR = "${INC_PR}.6"
+PR = "${INC_PR}.7"
QT_CONFIG_FLAGS_append_armv6 = " -no-neon "