summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt4/qt-mobility-embedded_1.2.0.bb
diff options
context:
space:
mode:
authorDmitry Cherukhin <dima_ch@emcraft.com>2011-10-06 15:56:19 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-17 13:32:23 +0100
commit5395ab6dc7cf3f1e1fd082b28cef50001d235750 (patch)
tree41485b204b4e36373724d37028afc13e51c1cb74 /meta/recipes-qt/qt4/qt-mobility-embedded_1.2.0.bb
parent1fdd82124834245f58680a44bdaacd1a264230b0 (diff)
downloadopenembedded-core-contrib-5395ab6dc7cf3f1e1fd082b28cef50001d235750.tar.gz
qt4: Added support for QtMobility 1.2
The QtMobility is a Qt add-on which allows to include standard mobile functionality to Qt applications. For details, see http://qt.nokia.com/products/qt-addons/mobility/ The patch is intended to add support for the QtMobility 1.2 package to OE. Added two recipes: 1) qt-mobility-x11 builds the QtMobility 1.2 package on the basis of Qt/X11 using the qt4-x11-free package; 2) qt-mobility-embedded builds the QtMobility 1.2 package on the basis of Qt/Embedded using the qt4-embedded package. Signed-off-by: Dmitry Cherukhin <dima_ch@emcraft.com>
Diffstat (limited to 'meta/recipes-qt/qt4/qt-mobility-embedded_1.2.0.bb')
-rw-r--r--meta/recipes-qt/qt4/qt-mobility-embedded_1.2.0.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt4/qt-mobility-embedded_1.2.0.bb b/meta/recipes-qt/qt4/qt-mobility-embedded_1.2.0.bb
new file mode 100644
index 0000000000..0c30e5fcf4
--- /dev/null
+++ b/meta/recipes-qt/qt4/qt-mobility-embedded_1.2.0.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Qt Mobility 1.2.0 - version for Qt/Embedded"
+DEPENDS = "qt4-embedded"
+SECTION = "libs"
+qtm_embedded := "embedded"
+qtm_dir = "qtopia"
+qtm_glflags := "-=opengl"
+qtm_extra_config := "gstreamer-photography_enabled = no"
+
+inherit qt4e
+require qt-mobility_${PV}.inc
+