summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt4-graphics-system
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-03 10:59:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-05 10:33:18 -0800
commit41bc192c0b5795561b239872008c91a867732219 (patch)
treea21feb51bde721ba553296676ce4b5ea2662bf37 /meta/recipes-qt/qt4-graphics-system
parent3b57de68e70e77dbc03c0616a83a29a2e99e40b4 (diff)
downloadopenembedded-core-contrib-41bc192c0b5795561b239872008c91a867732219.tar.gz
meta: Convert getVar/getVarFlag(xxx, 1) -> (xxx, True)
Using "1" with getVar is bad coding style and "True" is preferred. This patch is a sed over the meta directory of the form: sed \ -e 's:\(\.getVar([^,()]*, \)1 *):\1True):g' \ -e 's:\(\.getVarFlag([^,()]*, [^,()]*, \)1 *):\1True):g' \ -i `grep -ril getVar *` Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-qt/qt4-graphics-system')
-rw-r--r--meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb b/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
index b3aa1e559c..bae0340faf 100644
--- a/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
+++ b/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
@@ -9,7 +9,7 @@ QT_GRAPHICS_SYSTEM ?= "raster"
VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
def _get_extra_rdepends(d):
- gs = d.getVar('QT_GRAPHICS_SYSTEM', 1)
+ gs = d.getVar('QT_GRAPHICS_SYSTEM', True)
if gs == "opengl":
return "qt4-plugin-graphicssystems-glgraphicssystem"