summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt-demo
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-11-27 15:48:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-07 13:33:59 +0000
commitcb89d2b25b4edb1241bc5426a69a6bc44df9be2c (patch)
tree778d1166be782fff08ccef8c2eca505aaa49d4f4 /meta/recipes-qt/qt-demo
parent95fced137a46dc98863fe5af7be5cbce708602f2 (diff)
downloadopenembedded-core-contrib-cb89d2b25b4edb1241bc5426a69a6bc44df9be2c.tar.gz
qt4: remove recipes and classes
Qt4 is no longer supportd upstream, but it is still needed for LSB compliancy. Qt4 recipes have been moved to a separate meta-qt4 layer to be consistent with meta-qt3 and meta-qt5. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-qt/qt-demo')
-rw-r--r--meta/recipes-qt/qt-demo/qt-demo-init/qtdemo-init55
-rw-r--r--meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb19
2 files changed, 0 insertions, 74 deletions
diff --git a/meta/recipes-qt/qt-demo/qt-demo-init/qtdemo-init b/meta/recipes-qt/qt-demo/qt-demo-init/qtdemo-init
deleted file mode 100644
index 21f0273e2a..0000000000
--- a/meta/recipes-qt/qt-demo/qt-demo-init/qtdemo-init
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/sh
-
-set -e
-
-if [ -x /usr/bin/qtdemo ]; then
- QTDEMO="qtdemo"
-else
- QTDEMO="qtdemoE -qws"
-fi
-
-case "$1" in
- start)
- echo "Starting qtdemo"
- if [ -f /etc/profile.d/tslib.sh ]; then
- . /etc/profile.d/tslib.sh
- fi
- if [ -e "$TSLIB_TSDEVICE" ]; then
- if [ ! -f /etc/pointercal ]; then
- /usr/bin/ts_calibrate
- fi
- if [ "$QTDEMO" = "qtdemo" ]; then
- Xorg &
- export DISPLAY=:0
- $QTDEMO &
- else
- QWS_MOUSE_PROTO=tslib:$TSLIB_TSDEVICE $QTDEMO &
- fi
- else
- if [ "$QTDEMO" = "qtdemo" ]; then
- Xorg &
- export DISPLAY=:0
- fi
- $QTDEMO &
- fi
- ;;
- stop)
- echo "Stopping qtdemo"
- if [ "$QTDEMO" = "qtdemo" ]; then
- killall Xorg
- killall qtdemo
- else
- killall qtdemoE
- fi
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- *)
- echo "usage: $0 { start | stop | restart }" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb b/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb
deleted file mode 100644
index aa1b0b62f2..0000000000
--- a/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Init script for qtdemo"
-LICENSE = "MIT"
-SRC_URI = "file://qtdemo-init"
-PR = "r3"
-
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-S = "${WORKDIR}"
-
-do_install() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/qtdemo-init ${D}${sysconfdir}/init.d/qtdemo
-}
-
-inherit update-rc.d allarch
-
-INITSCRIPT_NAME = "qtdemo"
-INITSCRIPT_PARAMS = "start 99 5 2 . stop 19 0 1 6 ."