aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt-apps/qmmp_0.6.1.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-02-05 15:55:46 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-06 09:35:01 +0000
commit12484dca3bf09dd9a03442a223885deb7472a6cd (patch)
tree398ad1f9a2845d07f3da8354b1919ff0ad1788c1 /meta/recipes-qt/qt-apps/qmmp_0.6.1.bb
parent871549996cfcaf860083d867eb6a9522f4407cd4 (diff)
downloadopenembedded-core-contrib-12484dca3bf09dd9a03442a223885deb7472a6cd.tar.gz
qmmp: update to 0.6.6 and fix
* Update to 0.6.6 * Fix compilation failure due to unconditional call to QApplication::commitData() * Disable /usr/local host paths to avoid compilation warnings * Force use of the cmake configure instead of qmake as the latter is not dynamic with Qmmp and doesn't let you disable certain dependencies (e.g. enca) * Add libsndfile1, libsamplerate0 and curl to DEPENDS since their use will be non-deterministic otherwise * Explicitly disable library-requiring options that we don't have available in OE-Core so that they don't get used if they happen to be in the sysroot * Update LIC_FILES_CHKSUM since there were cosmetic changes to the license file (mostly reformatting and change of references to LGPL from "Library" to "Lesser".) Fixes [YOCTO #3822]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-qt/qt-apps/qmmp_0.6.1.bb')
-rw-r--r--meta/recipes-qt/qt-apps/qmmp_0.6.1.bb53
1 files changed, 0 insertions, 53 deletions
diff --git a/meta/recipes-qt/qt-apps/qmmp_0.6.1.bb b/meta/recipes-qt/qt-apps/qmmp_0.6.1.bb
deleted file mode 100644
index ed096e9ef4..0000000000
--- a/meta/recipes-qt/qt-apps/qmmp_0.6.1.bb
+++ /dev/null
@@ -1,53 +0,0 @@
-DESCRIPTION = "Qmmp (Qt-based Multimedia Player) is an audio-player, written with help of Qt library"
-HOMEPAGE = "http://qmmp.ylsoftware.com"
-LICENSE = "GPLv2"
-LICENSE_FLAGS = "commercial"
-LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
-SECTION = "multimedia"
-
-PR = "r1"
-
-DEPENDS = "taglib libmad libvorbis libogg alsa-lib"
-
-SRC_URI = "http://qmmp.ylsoftware.com/files/${BPN}-${PV}.tar.bz2"
-
-SRC_URI[md5sum] = "23a1a3aa924da901ebc8327ea76135d4"
-SRC_URI[sha256sum] = "b48be8c0e3882088919a77ce7b619cfc99d32af29cc688ba8749a58cbb25fb6f"
-
-inherit cmake qt4x11
-
-export EXTRA_OECMAKE = "-DQT_QMAKE_EXECUTABLE=${OE_QMAKE_QMAKE} \
- -DQT_LRELEASE_EXECUTABLE=${OE_QMAKE_LRELEASE} \
- -DQT_MOC_EXECUTABLE=${OE_QMAKE_MOC} \
- -DQT_UIC_EXECUTABLE=${OE_QMAKE_UIC} \
- -DQT_RCC_EXECUTABLE=${OE_QMAKE_RCC} \
- -DQT_LIBRARY_DIR=${OE_QMAKE_LIBDIR_QT} \
- -DQT_HEADERS_DIR=${OE_QMAKE_INCDIR_QT} \
- -DQT_QTCORE_INCLUDE_DIR=${OE_QMAKE_INCDIR_QT}/QtCore \
- "
-PACKAGES_DYNAMIC += "^qmmp-plugin-.* "
-
-
-python populate_packages_prepend () {
- qmmp_libdir = d.expand('${libdir}/qmmp')
- gd = d.expand('${D}/${libdir}/qmmp')
- plug_dirs = os.listdir(gd)
-
- for plug_dir in plug_dirs:
- g_plug_dir = os.path.join(qmmp_libdir,plug_dir)
- do_split_packages(d, g_plug_dir, '^lib(.*)\.so$', 'qmmp-plugin-' + plug_dir.lower() + '-%s', 'Qmmp' + plug_dir + 'plugin for %s')
-}
-
-FILES_${PN} = "\
- ${bindir}/qmmp \
- ${libdir}/lib*${SOLIBS} \
- ${datadir}/icons/* \
- ${datadir}/qmmp/images/* \
- ${datadir}/applications/* \
- "
-
-FILES_${PN}-dbg += "\
- ${libdir}/qmmp/*/.debug/* \
- "
-
-RDEPENDS_${PN} += "taglib alsa-lib libmad curl"