summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-04 17:43:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 18:03:13 +0100
commit5dd4de086d744c81d2275077ad0e0022204b0a68 (patch)
tree6ec64251dbcabb7098fcfd5157b800fb8ebc5490 /meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
parentc65f8af02ebba371f96119baef0520c6685c7167 (diff)
downloadopenembedded-core-contrib-5dd4de086d744c81d2275077ad0e0022204b0a68.tar.gz
packagegroup-*: add RREPLACES/RCONFLICTS
These are needed to support upgrading from task-* to packagegroup-* within existing target images at runtime. Note: these settings will very likely be moved out to a separate inc file at some point in the future. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-qt/packagegroups/packagegroup-core-qt.bb')
-rw-r--r--meta/recipes-qt/packagegroups/packagegroup-core-qt.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
index ed13354e46..315df3388d 100644
--- a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
+++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
@@ -4,7 +4,7 @@
DESCRIPTION = "Qt package groups"
LICENSE = "MIT"
-PR = "r3"
+PR = "r4"
inherit packagegroup
@@ -12,6 +12,8 @@ PACKAGES = "${PN}-demoapps"
# For backwards compatibility after rename
RPROVIDES_${PN}-demoapps = "task-core-qt-demos"
+RREPLACES_${PN}-demoapps = "task-core-qt-demos"
+RCONFLICTS_${PN}-demoapps = "task-core-qt-demos"
QTDEMOS ?= "quicky ${COMMERCIAL_QT} fotowall"