summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-29 11:38:34 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:50 -0700
commit424dcf7046e4ad09dcc664eb1992201195247fcf (patch)
tree26640470c5c7865aec06711fae7009304dc8fea0 /meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
parentecd818f1a7a46aa0eeffe48445f2cf0db5aab67a (diff)
downloadopenembedded-core-contrib-424dcf7046e4ad09dcc664eb1992201195247fcf.tar.gz
Rename task to packagegroup
"Package group" is a much more appropriate name for these than task, since we use the word task to describe units of work executed by BitBake. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-qt/packagegroups/packagegroup-core-qt.bb')
-rw-r--r--meta/recipes-qt/packagegroups/packagegroup-core-qt.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
new file mode 100644
index 0000000000..4fe07c654e
--- /dev/null
+++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 Intel Corporation. All rights reserved
+#
+
+DESCRIPTION = "Qt Tasks for Poky"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r3"
+
+PACKAGES = "\
+ packagegroup-core-qt-demos \
+ packagegroup-core-qt-demos-dbg \
+ packagegroup-core-qt-demos-dev \
+ "
+
+ALLOW_EMPTY = "1"
+
+QTDEMOS ?= "quicky ${COMMERCIAL_QT} fotowall"
+#QTDEMOS_disabled = "fotowall"
+
+RDEPENDS_packagegroup-core-qt-demos = "${QTDEMOS}"