aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2018-12-11 19:23:39 +0200
committerTanu Kaskinen <tanuk@iki.fi>2019-02-21 22:07:27 +0200
commit95ee8e9b49c65559e96214fd89531d0e8ea87bc9 (patch)
treeda82a3a1d79436fdbd52709d9900e685fb9341f3 /meta/recipes-multimedia
parentff2c029b568f70aa9960dde04ddd207829812ea0 (diff)
downloadopenembedded-core-contrib-95ee8e9b49c65559e96214fd89531d0e8ea87bc9.tar.gz
alsa-lib: 1.1.6 -> 1.1.8
Changelogs: http://alsa-project.org/main/index.php/Changes_v1.1.6_v1.1.7 http://alsa-project.org/main/index.php/Changes_v1.1.7_v1.1.8 One significant change was that the search path of add-on configuration files was changed from /usr/share/alsa/alsa.conf.d to /etc/alsa/conf.d. Packages that install such files should still use the /usr/share location, though. Symlinks need to be created from /etc to /usr/share. The rationale for using /etc is that the system administrator can better control the configuration that way, and the rationale for installing files under /usr/share is that configuration snippets that are installed by packages are not meant to be directly edited by the administrator. alsa-plugins had to be modified to add symlinks for the configuration snippets that it installs. I also added FILES_${PN} = "", because the alsa-plugins package is supposed to be empty, but also because for some reason that I don't understand the symlinks would otherwise go to the alsa-plugins package rather than alsa-plugins-pulseaudio-conf. SRC_URI was changed to a more reliable source (at least currently the ftp server is flaky). Signed-off-by: Tanu Kaskinen <tanuk@iki.fi>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb (renamed from meta/recipes-multimedia/alsa/alsa-lib_1.1.6.bb)6
-rw-r--r--meta/recipes-multimedia/alsa/alsa-plugins_1.1.6.bb13
2 files changed, 15 insertions, 4 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.1.6.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb
index 25e7a3c6b7..76cc9627e5 100644
--- a/meta/recipes-multimedia/alsa/alsa-lib_1.1.6.bb
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7 \
file://src/socket.c;md5=dd1bc7f44872690224d89c1a9806e495;beginline=1;endline=26 \
"
-SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/${BP}.tar.bz2"
-SRC_URI[md5sum] = "2f981a8f7897c59ec2ddc44916d33788"
-SRC_URI[sha256sum] = "5f2cd274b272cae0d0d111e8a9e363f08783329157e8dd68b3de0c096de6d724"
+SRC_URI = "https://www.alsa-project.org/files/pub/lib/${BP}.tar.bz2"
+SRC_URI[md5sum] = "0eec0d657a07927795809c8f87fb76ca"
+SRC_URI[sha256sum] = "3cdc3a93a6427a26d8efab4ada2152e64dd89140d981f6ffa003e85be707aedf"
inherit autotools pkgconfig
diff --git a/meta/recipes-multimedia/alsa/alsa-plugins_1.1.6.bb b/meta/recipes-multimedia/alsa/alsa-plugins_1.1.6.bb
index 7ede8be98a..ee06191ea9 100644
--- a/meta/recipes-multimedia/alsa/alsa-plugins_1.1.6.bb
+++ b/meta/recipes-multimedia/alsa/alsa-plugins_1.1.6.bb
@@ -47,14 +47,23 @@ PACKAGES_DYNAMIC = "^libasound-module-.*"
# The alsa-plugins package doesn't itself contain anything, it just depends on
# all built plugins.
+FILES_${PN} = ""
ALLOW_EMPTY_${PN} = "1"
do_install_append() {
rm ${D}${libdir}/alsa-lib/*.la
- # We use the example as is, so just drop the .example suffix.
if [ "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'yes', 'no', d)}" = "yes" ]; then
+ # We use the example as is, so just drop the .example suffix.
mv ${D}${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf.example ${D}${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf
+
+ # The conf.d files are installed in datadir, but alsa-lib
+ # searches for conf.d files only in sysconfdir. Distributions
+ # are expected to create symlinks in sysconfdir, so that's what
+ # we do here.
+ mkdir -p ${D}${sysconfdir}/alsa/conf.d
+ ln -s ${datadir}/alsa/alsa.conf.d/50-pulseaudio.conf ${D}${sysconfdir}/alsa/conf.d/50-pulseaudio.conf
+ ln -s ${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf ${D}${sysconfdir}/alsa/conf.d/99-pulseaudio-default.conf
fi
}
@@ -94,6 +103,8 @@ INSANE_SKIP_${MLPREFIX}libasound-module-rate-speexrate = "dev-so"
FILES_${PN}-pulseaudio-conf += "\
${datadir}/alsa/alsa.conf.d/50-pulseaudio.conf \
${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf \
+ ${sysconfdir}/alsa/conf.d/50-pulseaudio.conf \
+ ${sysconfdir}/alsa/conf.d/99-pulseaudio-default.conf \
"
RDEPENDS_${PN}-pulseaudio-conf += "\