aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-10-18 23:03:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-15 11:54:44 +0000
commit2d34fc0ce21fe06ff97208c8ffb65a718b444de9 (patch)
tree7e644f47d77c75be08200b13498b08b6f3779227 /meta/recipes-multimedia
parent4ed8241b58ad3180311fc20cb6ef26acf44058b4 (diff)
downloadopenembedded-core-contrib-2d34fc0ce21fe06ff97208c8ffb65a718b444de9.tar.gz
libatomics-ops: force ARM mode
* otherwise ie spitz (armv5te) build fails with: | make[3]: Entering directory `/OE/shr-core/tmp/work/armv5te-oe-linux-gnueabi/libatomics-ops-1.2-r5/libatomic_ops-1.2/src' | arm-oe-linux-gnueabi-gcc -march=armv5te -mthumb -mthumb-interwork -mtune=xscale --sysroot=/OE/shr-core/tmp/sysroots/spitz -DHAVE_CONFIG_H -I. -fPIC -O 2 -pipe -g -feliminate-unused-debug-types -DNDEBUG -c atomic_ops.c | arm-oe-linux-gnueabi-gcc -march=armv5te -mthumb -mthumb-interwork -mtune=xscale --sysroot=/OE/shr-core/tmp/sysroots/spitz -DHAVE_CONFIG_H -I. -fPIC -O 2 -pipe -g -feliminate-unused-debug-types -DNDEBUG -c atomic_ops_stack.c | arm-oe-linux-gnueabi-gcc -march=armv5te -mthumb -mthumb-interwork -mtune=xscale --sysroot=/OE/shr-core/tmp/sysroots/spitz -DHAVE_CONFIG_H -I. -fPIC -O 2 -pipe -g -feliminate-unused-debug-types -DNDEBUG -c atomic_ops_malloc.c | atomic_ops_malloc.c: In function 'msb': | atomic_ops_malloc.c:223:2: warning: right shift count >= width of type [enabled by default] | rm -f libatomic_ops_gpl.a | ar cru libatomic_ops_gpl.a atomic_ops_stack.o atomic_ops_malloc.o | arm-oe-linux-gnueabi-ranlib libatomic_ops_gpl.a | {standard input}: Assembler messages: | {standard input}:286: Error: selected processor does not support Thumb mode `swp r1,r2,[r3]' | {standard input}:329: Error: selected processor does not support Thumb mode `swp r0,r1,[r3]' * this is just work around, proper fix proposed by Henning Heinold hm we should think of reworking this recipe now. Because since gcc 4.5 pulseaudio for arm can use the gcc internal atomicstuff and in oe-core and meta-oe we have 4.5 or 4.6 only. The lib is only needed for mips and it is still the old release, on cvs is a much better version, which supports thumb too, if remember correctly. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/pulseaudio/libatomics-ops_1.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/pulseaudio/libatomics-ops_1.2.bb b/meta/recipes-multimedia/pulseaudio/libatomics-ops_1.2.bb
index ab7ccbe816..c84917a7b3 100644
--- a/meta/recipes-multimedia/pulseaudio/libatomics-ops_1.2.bb
+++ b/meta/recipes-multimedia/pulseaudio/libatomics-ops_1.2.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2 & MIT"
LIC_FILES_CHKSUM = "file://doc/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://doc/LICENSING.txt;md5=607073e04548eac7d1f763e480477bab \
"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://www.hpl.hp.com/research/linux/atomic_ops/download/libatomic_ops-${PV}.tar.gz \
file://fedora/libatomic_ops-1.2-ppclwzfix.patch \
@@ -20,6 +20,8 @@ S = "${WORKDIR}/libatomic_ops-${PV}"
ALLOW_EMPTY_${PN} = "1"
+ARM_INSTRUCTION_SET = "arm"
+
inherit autotools pkgconfig
do_install_append() {