aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-18 17:32:02 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:41 +0000
commita38b5c3ae8cce8870aa7276feaeefdd52dbcda8c (patch)
tree089b35b043bb065cadaacf0ed75bb7a7ac8334c3 /meta/recipes-multimedia
parentfb839d7c244b53e555d02cad747617aacf63d1a3 (diff)
downloadopenembedded-core-contrib-a38b5c3ae8cce8870aa7276feaeefdd52dbcda8c.tar.gz
gstreamer1.0-libav: minor formatting improvements + update HOMEPAGE
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc15
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.6.2.bb5
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_git.bb4
3 files changed, 13 insertions, 11 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc
index 3948b401c5..c3c7d5bc06 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav.inc
@@ -1,8 +1,10 @@
SUMMARY = "Libav-based GStreamer 1.x plugin"
+HOMEPAGE = "http://gstreamer.freedesktop.org/"
SECTION = "multimedia"
+
LICENSE = "GPLv2+ & LGPLv2+ & ( (GPLv2+ & LGPLv2.1+) | (GPLv3+ & LGPLv3+) )"
LICENSE_FLAGS = "commercial"
-HOMEPAGE = "http://www.gstreamer.net/"
+
DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base zlib bzip2 xz"
inherit autotools pkgconfig upstream-version-is-even
@@ -10,12 +12,12 @@ inherit autotools pkgconfig upstream-version-is-even
# CAUTION: Using the system libav is not recommended. Since the libav API is changing all the time,
# compilation errors (and other, more subtle bugs) can happen. It is usually better to rely on the
# libav copy included in the gst-libav package.
-PACKAGECONFIG ??= " orc yasm "
-PACKAGECONFIG[libav] = "--with-system-libav,,libav"
-PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl,"
-PACKAGECONFIG[yasm] = "--enable-yasm,--disable-yasm,yasm-native"
-PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc"
+PACKAGECONFIG ??= "orc yasm"
+PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl,"
+PACKAGECONFIG[libav] = "--with-system-libav,,libav"
+PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc"
+PACKAGECONFIG[yasm] = "--enable-yasm,--disable-yasm,yasm-native"
GSTREAMER_1_0_DEBUG ?= "--disable-debug"
@@ -28,4 +30,3 @@ EXTRA_OECONF = "${LIBAV_EXTRA_CONFIGURE_COMMON}"
FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la"
FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
-
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.6.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.6.2.bb
index 1091b841a7..77e0655dac 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.6.2.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.6.2.bb
@@ -13,17 +13,18 @@ SRC_URI = " \
file://0001-Disable-yasm-for-libav-when-disable-yasm.patch \
file://workaround-to-build-gst-libav-for-i586-with-gcc.patch \
"
+
SRC_URI[md5sum] = "09644a38827d233f53edeac815dd0ec0"
SRC_URI[sha256sum] = "2597acc00171006d49f0d300440a87df51b113d557466e532153abc740db3469"
+S = "${WORKDIR}/gst-libav-${PV}"
+
LIBAV_EXTRA_CONFIGURE_COMMON_ARG = "--target-os=linux \
--cc='${CC}' --as='${CC}' --ld='${CC}' --nm='${NM}' --ar='${AR}' \
--ranlib='${RANLIB}' \
${GSTREAMER_1_0_DEBUG} \
--cross-prefix='${HOST_PREFIX}'"
-S = "${WORKDIR}/gst-libav-${PV}"
-
# http://errors.yoctoproject.org/Errors/Details/20493/
ARM_INSTRUCTION_SET_armv4 = "arm"
ARM_INSTRUCTION_SET_armv5 = "arm"
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_git.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_git.bb
index bf1b87e6de..32f4814f62 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_git.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_git.bb
@@ -12,10 +12,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://gst-libs/ext/libav/COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
SRC_URI = "git://anongit.freedesktop.org/gstreamer/gst-libav;branch=master"
-S = "${WORKDIR}/git"
SRCREV = "127202d6f65584891dabf92be031f0d170b0e7f1"
+S = "${WORKDIR}/git"
+
LIBAV_EXTRA_CONFIGURE_COMMON_ARG = "--target-os=linux \
--cc='${CC}' --as='${CC}' --ld='${CC}' --nm='${NM}' --ar='${AR}' \
${GSTREAMER_1_0_DEBUG} \
@@ -26,4 +27,3 @@ do_configure_prepend() {
./autogen.sh --noconfigure
cd ${B}
}
-