aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-10-18 10:51:56 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-18 11:27:31 +0100
commit644e54fef907172487f860b09ad1faf4b6db9e11 (patch)
tree2a2fb53d2c3c8bb786d76db75c80764f1a9bff30 /meta/recipes-multimedia
parentf8c6335e95587a797b0be8cf82315798278069e4 (diff)
downloadopenembedded-core-contrib-644e54fef907172487f860b09ad1faf4b6db9e11.tar.gz
gstreamer: add support for theora plugins
Add theora codec and its corresponding lib recipe (import from OE). This fixes [BUGID #476]. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb3
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.29.bb6
-rw-r--r--meta/recipes-multimedia/libtheora/libtheora-1.1.1/no-docs.patch13
-rw-r--r--meta/recipes-multimedia/libtheora/libtheora_1.1.1.bb14
4 files changed, 32 insertions, 4 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb b/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb
index 30adf7a5cf..4d6db6da58 100644
--- a/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Gstreamer package groups"
LICENSE = "MIT"
DEPENDS = "gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad"
-PR = "r7"
+PR = "r8"
PACKAGES = "\
gst-meta-base \
@@ -48,6 +48,7 @@ RDEPENDS_gst-meta-video = "\
gst-meta-base \
gst-plugins-good-avi \
gst-plugins-good-matroska \
+ gst-plugins-base-theora \
${COMMERCIAL_VIDEO_PLUGINS}"
RRECOMMENDS_gst-meta-video = "\
diff --git a/meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.29.bb b/meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.29.bb
index bfbe28108d..c1d2f1e9dd 100644
--- a/meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.29.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.29.bb
@@ -6,15 +6,15 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
file://gst/ffmpegcolorspace/utils.c;beginline=1;endline=20;md5=9c83a200b8e597b26ca29df20fc6ecd0"
-DEPENDS += "virtual/libx11 alsa-lib freetype gnome-vfs liboil libogg libvorbis libxv"
+DEPENDS += "virtual/libx11 alsa-lib freetype gnome-vfs liboil libogg libvorbis libxv libtheora"
RDEPENDS += "gnome-vfs-plugin-file gnome-vfs-plugin-http gnome-vfs-plugin-ftp \
gnome-vfs-plugin-sftp"
-PR = "r0"
+PR = "r1"
inherit gettext
-EXTRA_OECONF += "--disable-freetypetest --disable-pango --disable-theora"
+EXTRA_OECONF += "--disable-freetypetest --disable-pango"
do_configure_prepend() {
# This m4 file contains nastiness which conflicts with libtool 2.2.2
diff --git a/meta/recipes-multimedia/libtheora/libtheora-1.1.1/no-docs.patch b/meta/recipes-multimedia/libtheora/libtheora-1.1.1/no-docs.patch
new file mode 100644
index 0000000000..5734bce465
--- /dev/null
+++ b/meta/recipes-multimedia/libtheora/libtheora-1.1.1/no-docs.patch
@@ -0,0 +1,13 @@
+Index: libtheora-1.1.1/Makefile.am
+===================================================================
+--- libtheora-1.1.1.orig/Makefile.am 2009-11-25 22:01:53.593775926 +0100
++++ libtheora-1.1.1/Makefile.am 2009-11-25 22:02:00.777524017 +0100
+@@ -8,7 +8,7 @@
+ EXAMPLES_DIR =
+ endif
+
+-SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR)
++SUBDIRS = lib include tests m4 $(EXAMPLES_DIR)
+
+
+ # we include the whole debian/ dir in EXTRA_DIST because there's a problem
diff --git a/meta/recipes-multimedia/libtheora/libtheora_1.1.1.bb b/meta/recipes-multimedia/libtheora/libtheora_1.1.1.bb
new file mode 100644
index 0000000000..6e73a790f2
--- /dev/null
+++ b/meta/recipes-multimedia/libtheora/libtheora_1.1.1.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "The libtheora reference implementation provides the standard encoder and decoder under a BSD license."
+HOMEPAGE = "http://xiph.org/"
+BUGTRACKER = "https://trac.xiph.org/newticket"
+SECTION = "libs"
+LICENSE = "BSD"
+
+PR = "r0"
+
+SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-${PV}.tar.bz2 \
+ file://no-docs.patch"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-examples"