aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-26 16:23:31 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-30 11:36:59 +0000
commit6e90145ed9423ad37dbbd61c336d835ca7715da9 (patch)
tree93b4c67d688defe4a51c9837586aba71281ee3f1 /meta/recipes-multimedia
parent3cd70c8edb357ff1a8d1e3e1fb09d94224bb936c (diff)
downloadopenembedded-core-contrib-6e90145ed9423ad37dbbd61c336d835ca7715da9.tar.gz
gstreamer1.0-plugins-good: fix compiler warnings with -Os in 1.7.1
(From OE-Core rev: 3890ac52f3f1ef69504bea421aa3c7b57616a362) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch41
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_git.bb1
2 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch
new file mode 100644
index 0000000000..59addaed43
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch
@@ -0,0 +1,41 @@
+From 63a838d9ae2be480be8d28d6f51762d288b2a54a Mon Sep 17 00:00:00 2001
+From: Andre McCurdy <armccurdy@gmail.com>
+Date: Tue, 26 Jan 2016 14:47:36 -0800
+Subject: [PATCH] fix maybe-uninitialized warnings when compiling with -Os
+
+Upstream-Status: Pending
+
+Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
+---
+ gst/isomp4/qtdemux.c | 1 +
+ gst/rtp/gstrtph261pay.c | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/gst/isomp4/qtdemux.c b/gst/isomp4/qtdemux.c
+index 77bb73e..1fc60ac 100644
+--- a/gst/isomp4/qtdemux.c
++++ b/gst/isomp4/qtdemux.c
+@@ -3269,6 +3269,7 @@ qtdemux_parse_cenc_aux_info (GstQTDemux * qtdemux, QtDemuxStream * stream,
+ gst_structure_set (properties, "iv", GST_TYPE_BUFFER, buf, NULL);
+ size = info_sizes[i];
+ if (size > iv_size) {
++ n_subsamples = 0;
+ if (!gst_byte_reader_get_uint16_be (br, &n_subsamples)
+ || !(n_subsamples > 0)) {
+ gst_structure_free (properties);
+diff --git a/gst/rtp/gstrtph261pay.c b/gst/rtp/gstrtph261pay.c
+index 7cdd323..ebcf80e 100644
+--- a/gst/rtp/gstrtph261pay.c
++++ b/gst/rtp/gstrtph261pay.c
+@@ -867,7 +867,7 @@ gst_rtp_h261_packetize_and_push (GstRtpH261Pay * pay, GstBuffer * buffer,
+ gst_rtp_buffer_calc_payload_len (GST_RTP_BASE_PAYLOAD_MTU (pay) -
+ GST_RTP_H261_PAYLOAD_HEADER_LEN, 0, 0);
+ guint startpos;
+- gint num_gobs;
++ gint num_gobs = 0;
+ Gob gobs[MAX_NUM_GOB];
+ Gob *gob;
+ Macroblock last_mb_in_previous_packet = { 0 };
+--
+1.9.1
+
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_git.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_git.bb
index 88137ee2a6..5f36f496e5 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_git.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_git.bb
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
SRC_URI = " \
git://anongit.freedesktop.org/gstreamer/gst-plugins-good;name=base \
git://anongit.freedesktop.org/gstreamer/common;destsuffix=git/common;name=common \
+ file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \
"
PV = "1.7.1+git${SRCPV}"