aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/x264
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-11-08 07:19:32 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-15 15:18:49 +0000
commit8f132ca02c0d8abe309b622cfeef5f21ecc0b242 (patch)
tree6503654c4ff5450f9c4d9f6a4d55431661faf898 /meta/recipes-multimedia/x264
parent62771b5a426e4b7d38e4997dc3f252a547f481ce (diff)
downloadopenembedded-core-contrib-8f132ca02c0d8abe309b622cfeef5f21ecc0b242.tar.gz
x264: Update to latest on stable branch
- unexport AS variable - Switch URI to use github mirror for reliabality - Disable openCL code, its not used - TEXTRELs are fixed, therefore dont skip QA check Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/x264')
-rw-r--r--meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch13
-rw-r--r--meta/recipes-multimedia/x264/x264_git.bb11
2 files changed, 6 insertions, 18 deletions
diff --git a/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch b/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
index bf72fca682..73f2aac613 100644
--- a/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
+++ b/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
@@ -5,10 +5,10 @@ Upstream-Status: Pending
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
diff --git a/configure b/configure
-index 2916036..f4ece40 100755
+index 9d1586c..3109ec4 100755
--- a/configure
+++ b/configure
-@@ -773,9 +773,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \) ] ; then
+@@ -874,9 +874,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \) ] ; then
fi
if [ $asm = auto -a $ARCH = ARM ] ; then
@@ -18,12 +18,3 @@ index 2916036..f4ece40 100755
if cc_check '' '' '__asm__("rev ip, ip");' ; then define HAVE_ARMV6
cc_check '' '' '__asm__("movt r0, #0");' && define HAVE_ARMV6T2
cc_check '' '' '__asm__("vadd.i16 q0, q0, q0");' && define HAVE_NEON
-@@ -788,8 +785,6 @@ if [ $asm = auto -a $ARCH = ARM ] ; then
- fi
-
- if [ $asm = auto -a $ARCH = AARCH64 ] ; then
-- # set flags so neon is built by default
-- echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu|-arch)' || CFLAGS="$CFLAGS -arch arm64 -mfpu=neon"
-
- if cc_check '' '' '__asm__("cmeq v0.8h, v0.8h, #0");' ; then define HAVE_NEON
- ASFLAGS="$ASFLAGS -c"
diff --git a/meta/recipes-multimedia/x264/x264_git.bb b/meta/recipes-multimedia/x264/x264_git.bb
index 393310f684..e790681ad3 100644
--- a/meta/recipes-multimedia/x264/x264_git.bb
+++ b/meta/recipes-multimedia/x264/x264_git.bb
@@ -8,11 +8,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "yasm-native"
-SRC_URI = "git://git.videolan.org/x264.git \
+SRC_URI = "git://github.com/mirror/x264;branch=stable \
file://don-t-default-to-cortex-a9-with-neon.patch \
"
-SRCREV = "c8a773ebfca148ef04f5a60d42cbd7336af0baf6"
+SRCREV = "86b71982e131eaa70125f8d0e725fcade9c4c677"
PV = "r2491+git${SRCPV}"
@@ -34,6 +34,7 @@ EXTRA_OECONF = '--prefix=${prefix} \
--enable-static \
--disable-lavf \
--disable-swscale \
+ --disable-opencl \
--enable-pic \
${X264_DISABLE_ASM} \
'
@@ -42,12 +43,8 @@ do_configure() {
./configure ${EXTRA_OECONF}
}
-AS = "${TARGET_PREFIX}gcc"
-
do_install() {
oe_runmake install DESTDIR=${D}
}
-# PIC can't be enabled for few BSP's
-INSANE_SKIP_${PN}_append = " textrel"
-
+AS[unexport] = "1"