aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/x264
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-06-08 22:28:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:55:44 +0100
commit2c8d6320ca4db7f7158a3e69467bee5c8ca8fed5 (patch)
tree59df42db683fa7b7ba280d9af30fe61446df1557 /meta/recipes-multimedia/x264
parent1bbd105c12b9b0a28973e7796fc2d18543b17abf (diff)
downloadopenembedded-core-contrib-2c8d6320ca4db7f7158a3e69467bee5c8ca8fed5.tar.gz
x264: r2265 -> r2491
Update don-t-default-to-cortex-a9-with-neon.patch for aarch64. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-multimedia/x264')
-rw-r--r--meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch21
-rw-r--r--meta/recipes-multimedia/x264/x264_git.bb4
2 files changed, 17 insertions, 8 deletions
diff --git a/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch b/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
index b844d88fe8..bf72fca682 100644
--- a/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
+++ b/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
@@ -4,13 +4,13 @@
Upstream-Status: Pending
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
-Index: git/configure
-===================================================================
---- git.orig/configure 2013-02-10 16:26:40.666343682 +0200
-+++ git/configure 2013-02-10 16:27:49.198341677 +0200
-@@ -703,9 +703,6 @@
+diff --git a/configure b/configure
+index 2916036..f4ece40 100755
+--- a/configure
++++ b/configure
+@@ -773,9 +773,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \) ] ; then
fi
-
+
if [ $asm = auto -a $ARCH = ARM ] ; then
- # set flags so neon is built by default
- echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu)' || CFLAGS="$CFLAGS -mcpu=cortex-a8 -mfpu=neon"
@@ -18,3 +18,12 @@ Index: git/configure
if cc_check '' '' '__asm__("rev ip, ip");' ; then define HAVE_ARMV6
cc_check '' '' '__asm__("movt r0, #0");' && define HAVE_ARMV6T2
cc_check '' '' '__asm__("vadd.i16 q0, q0, q0");' && define HAVE_NEON
+@@ -788,8 +785,6 @@ if [ $asm = auto -a $ARCH = ARM ] ; then
+ fi
+
+ if [ $asm = auto -a $ARCH = AARCH64 ] ; then
+- # set flags so neon is built by default
+- echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu|-arch)' || CFLAGS="$CFLAGS -arch arm64 -mfpu=neon"
+
+ if cc_check '' '' '__asm__("cmeq v0.8h, v0.8h, #0");' ; then define HAVE_NEON
+ ASFLAGS="$ASFLAGS -c"
diff --git a/meta/recipes-multimedia/x264/x264_git.bb b/meta/recipes-multimedia/x264/x264_git.bb
index 105ccae177..0a69909808 100644
--- a/meta/recipes-multimedia/x264/x264_git.bb
+++ b/meta/recipes-multimedia/x264/x264_git.bb
@@ -12,9 +12,9 @@ SRC_URI = "git://git.videolan.org/x264.git \
file://don-t-default-to-cortex-a9-with-neon.patch \
"
-SRCREV = "ffc3ad4945da69f3caa2b40e4eed715a9a8d9526"
+SRCREV = "c8a773ebfca148ef04f5a60d42cbd7336af0baf6"
-PV = "r2265+git${SRCPV}"
+PV = "r2491+git${SRCPV}"
S = "${WORKDIR}/git"