aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/speex
diff options
context:
space:
mode:
authorTanu Kaskinen <tanu.kaskinen@linux.intel.com>2015-07-09 13:43:14 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-16 15:09:15 +0100
commit505e1af8f629c8fc868d4e8f048f492f34bee969 (patch)
tree21fc49f276da02ac89be19120ee068781e0e82aa /meta/recipes-multimedia/speex
parentd8c34285e15c636ef08cfe42d15890984b12280e (diff)
downloadopenembedded-core-contrib-505e1af8f629c8fc868d4e8f048f492f34bee969.tar.gz
speex: 1.2rc1 -> 1.2rc2
Dropped speex-fpu.inc, since it's simpler to put the logic directly in the .bb file. LIC_FILES_CHKSUM changed due to whitespace changes only. Dropped PR. Added a dependency on speexdsp. The speexdsp functionality used to be included in speex, but upstream split the speexdsp package off into a separate source tree. speexdsp could otherwise be an optional dependency, but the upstream configure script doesn't support disabling it explicitly, and relying on automatic detection would make builds nondeterministic, so it's better to always enable it. --enable-fixed-point was previously included in the configure options unconditionally, but the option should be used only when TARGET_FPU is set to "soft". --with-ogg-libraries, --with-ogg-includes and --disable-oggtest aren't supported anymore, since speex now uses pkg-config to find libogg. (From OE-Core rev: c79cc4ab8455652d2ebd1132fdc868cf80ff81d0) (From OE-Core rev: 53ca5eac8942ba1c882b31a51f344f92746f9b06) Signed-off-by: Tanu Kaskinen <tanu.kaskinen@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/speex')
-rw-r--r--meta/recipes-multimedia/speex/speex-fpu.inc4
-rw-r--r--meta/recipes-multimedia/speex/speex_1.2rc2.bb (renamed from meta/recipes-multimedia/speex/speex_1.2rc1.bb)18
2 files changed, 7 insertions, 15 deletions
diff --git a/meta/recipes-multimedia/speex/speex-fpu.inc b/meta/recipes-multimedia/speex/speex-fpu.inc
deleted file mode 100644
index 2571d32484..0000000000
--- a/meta/recipes-multimedia/speex/speex-fpu.inc
+++ /dev/null
@@ -1,4 +0,0 @@
-def get_speex_fpu_setting(bb, d):
- if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
- return "--enable-fixed-point --disable-float-api --disable-vbr"
- return ""
diff --git a/meta/recipes-multimedia/speex/speex_1.2rc1.bb b/meta/recipes-multimedia/speex/speex_1.2rc2.bb
index 5ff50b7383..f7d23dbd7c 100644
--- a/meta/recipes-multimedia/speex/speex_1.2rc1.bb
+++ b/meta/recipes-multimedia/speex/speex_1.2rc2.bb
@@ -4,20 +4,16 @@ HOMEPAGE = "http://www.speex.org"
SECTION = "libs"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=314649d8ba9dd7045dfb6683f298d0a8 \
- file://include/speex/speex.h;beginline=1;endline=34;md5=a68129f78d7fe66e07163f73aba143b3"
-DEPENDS = "libogg"
-
-PR = "r2"
+ file://include/speex/speex.h;beginline=1;endline=34;md5=ef8c8ea4f7198d71cf3509c6ed05ea50"
+DEPENDS = "libogg speexdsp"
SRC_URI = "http://downloads.us.xiph.org/releases/speex/speex-${PV}.tar.gz"
-SRC_URI[md5sum] = "c4438b22c08e5811ff10e2b06ee9b9ae"
-SRC_URI[sha256sum] = "342f30dc57bd4a6dad41398365baaa690429660b10d866b7d508e8f1179cb7a6"
+SRC_URI[md5sum] = "6ae7db3bab01e1d4b86bacfa8ca33e81"
+SRC_URI[sha256sum] = "caa27c7247ff15c8521c2ae0ea21987c9e9710a8f2d3448e8b79da9806bce891"
inherit autotools pkgconfig lib_package
-EXTRA_OECONF = " --enable-fixed-point --with-ogg-libraries=${STAGING_LIBDIR} \
- --with-ogg-includes=${STAGING_INCDIR} --disable-oggtest"
-
-require speex-fpu.inc
-EXTRA_OECONF += "${@get_speex_fpu_setting(bb, d)}"
+EXTRA_OECONF = "\
+ ${@bb.utils.contains('TARGET_FPU', 'soft', '--enable-fixed-point --disable-float-api --disable-vbr', '', d)} \
+"