aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtheora
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-10-18 10:51:56 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-18 11:27:31 +0100
commit644e54fef907172487f860b09ad1faf4b6db9e11 (patch)
tree2a2fb53d2c3c8bb786d76db75c80764f1a9bff30 /meta/recipes-multimedia/libtheora
parentf8c6335e95587a797b0be8cf82315798278069e4 (diff)
downloadopenembedded-core-contrib-644e54fef907172487f860b09ad1faf4b6db9e11.tar.gz
gstreamer: add support for theora plugins
Add theora codec and its corresponding lib recipe (import from OE). This fixes [BUGID #476]. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/libtheora')
-rw-r--r--meta/recipes-multimedia/libtheora/libtheora-1.1.1/no-docs.patch13
-rw-r--r--meta/recipes-multimedia/libtheora/libtheora_1.1.1.bb14
2 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtheora/libtheora-1.1.1/no-docs.patch b/meta/recipes-multimedia/libtheora/libtheora-1.1.1/no-docs.patch
new file mode 100644
index 0000000000..5734bce465
--- /dev/null
+++ b/meta/recipes-multimedia/libtheora/libtheora-1.1.1/no-docs.patch
@@ -0,0 +1,13 @@
+Index: libtheora-1.1.1/Makefile.am
+===================================================================
+--- libtheora-1.1.1.orig/Makefile.am 2009-11-25 22:01:53.593775926 +0100
++++ libtheora-1.1.1/Makefile.am 2009-11-25 22:02:00.777524017 +0100
+@@ -8,7 +8,7 @@
+ EXAMPLES_DIR =
+ endif
+
+-SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR)
++SUBDIRS = lib include tests m4 $(EXAMPLES_DIR)
+
+
+ # we include the whole debian/ dir in EXTRA_DIST because there's a problem
diff --git a/meta/recipes-multimedia/libtheora/libtheora_1.1.1.bb b/meta/recipes-multimedia/libtheora/libtheora_1.1.1.bb
new file mode 100644
index 0000000000..6e73a790f2
--- /dev/null
+++ b/meta/recipes-multimedia/libtheora/libtheora_1.1.1.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "The libtheora reference implementation provides the standard encoder and decoder under a BSD license."
+HOMEPAGE = "http://xiph.org/"
+BUGTRACKER = "https://trac.xiph.org/newticket"
+SECTION = "libs"
+LICENSE = "BSD"
+
+PR = "r0"
+
+SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-${PV}.tar.bz2 \
+ file://no-docs.patch"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-examples"