aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-18 19:53:28 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:42 +0000
commit0ec2a80f3300065824d6c980101e7f3af2cbe7aa (patch)
tree2d36dac4cc9915cd29b9ee8685a5def2acb206b8 /meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
parentba0a9db62a067852e346d986c338427b87e2f3fd (diff)
downloadopenembedded-core-contrib-0ec2a80f3300065824d6c980101e7f3af2cbe7aa.tar.gz
gstreamer1.0-plugins.inc: don't set base SRC_URI via python
Setting the SRC_URI via python for the four gstreamer1.0-plugins-XXX packages adds complexity and breaks consistency with the other plugins packages and with gstreamer itself (which all also fetch from freedesktop.org URLs but set SRC_URI conventionally). Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc22
1 files changed, 0 insertions, 22 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
index f179ce9b5b..fd0d8bd413 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
@@ -32,25 +32,3 @@ oe_runconf_prepend() {
sed -i -e "1a\\" -e 'GETTEXT_PACKAGE = @GETTEXT_PACKAGE@' ${S}/po/Makefile.in.in
fi
}
-
-SRC_URI = "${@get_gst_srcuri(d)}"
-
-GSTREAMER_1_0_GIT_BRANCH ?= "master"
-
-def get_gst_srcuri(d):
- # check if expected prefix is present
- prefix = "gstreamer1.0-"
- bpn = d.getVar("BPN", True)
- if not bpn.startswith(prefix):
- bb.fatal('Invalid GStreamer 1.0 plugin package name "%s" : must start with "%s"' % (bpn, prefix))
-
- # replaced prefix with "gst-", which is what is used for the tarball and repository filenames
- gstpkg_basename = "gst-" + bpn[len(prefix):]
- pv = d.getVar("PV", True)
- branch = d.getVar("GSTREAMER_1_0_GIT_BRANCH", True)
-
- if pv == "git":
- s = "git://anongit.freedesktop.org/gstreamer/%s;branch=%s" % (gstpkg_basename, branch)
- else:
- s = "http://gstreamer.freedesktop.org/src/%s/%s-%s.tar.xz" % (gstpkg_basename, gstpkg_basename, pv)
- return s