aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-06-24 11:26:27 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-25 17:44:57 +0100
commit26c858a653a5f96120078c8dd1bcf317ec5d32e1 (patch)
tree4fb358ebcc89dd81f6d0938b413abef7df5e5372 /meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bb
parent3a6f6392ec878ad3a25cdf844be74f897b9cb520 (diff)
downloadopenembedded-core-contrib-26c858a653a5f96120078c8dd1bcf317ec5d32e1.tar.gz
gst-plugins-base: element selection rationalisation
Use PACKAGECONFIG to control the X11 elements, and add statements for the elements that we don't always enable. Remove the freetype dependency as it's apparently (but not really) only needed by the examples. (From OE-Core rev: d40606de85a42c48327dead5d6e4c9a1de2cc39c) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bb12
1 files changed, 9 insertions, 3 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bb b/meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bb
index 462c54d816..26c562c05c 100644
--- a/meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bb
@@ -6,8 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
file://gst/ffmpegcolorspace/utils.c;beginline=1;endline=20;md5=9c83a200b8e597b26ca29df20fc6ecd0"
-DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxv libsm libice', '', d)}"
-DEPENDS += "alsa-lib freetype liboil libogg libvorbis libtheora util-linux tremor"
+DEPENDS += "alsa-lib liboil libogg libvorbis libtheora util-linux tremor"
SRC_URI += "file://gst-plugins-base-tremor.patch \
file://configure.ac-fix-subparse-plugin.patch"
@@ -19,7 +18,14 @@ PR = "r7"
inherit gettext
-EXTRA_OECONF += "--disable-freetypetest --disable-pango --disable-gnome_vfs --disable-orc"
+EXTRA_OECONF += "--disable-freetypetest"
+
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
+
+PACKAGECONFIG[gnomevfs] = "--enable-gnome_vfs,--disable-gnome_vfs,gnome-vfs"
+PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc"
+PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
+PACKAGECONFIG[x11] = "--enable-x --enable-xvideo,--disable-x --disable-xvideo,virtual/libx11 libxv libsm libice"
do_configure_prepend() {
# This m4 file contains nastiness which conflicts with libtool 2.2.2