aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-lsb4
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-08-31 18:00:10 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-10 12:58:59 +0100
commitaf5141135d0888ea1f72cd63c454bc82884ec567 (patch)
tree58e066d6379772164e3f0a888f7016e44aa580a2 /meta/recipes-lsb4
parent16be305db800c976e6241973e0cf176b954de8e4 (diff)
downloadopenembedded-core-contrib-af5141135d0888ea1f72cd63c454bc82884ec567.tar.gz
libfile-checktree-perl: add it
LSB perl test 4.1.6-2, all/tst_perlModPresent.pl 1 fails with: test 88 'use File::CheckTree;' failed Add it to fix this issue. [Yocto #3031] Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-lsb4')
-rw-r--r--meta/recipes-lsb4/perl/libfile-checktree-perl_4.41.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-lsb4/perl/libfile-checktree-perl_4.41.bb b/meta/recipes-lsb4/perl/libfile-checktree-perl_4.41.bb
new file mode 100644
index 0000000000..f11db5e2b4
--- /dev/null
+++ b/meta/recipes-lsb4/perl/libfile-checktree-perl_4.41.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Perl module that run many filetest checks on a tree"
+DESCRIPTION = "The validate() routine takes a single multiline string consisting \
+of directives, each containing a filename plus a file test to try on it. (The file \
+test may also be a "cd", causing subsequent relative filenames to be interpreted \
+relative to that directory.) After the file test you may put || die to make it a \
+fatal error if the file test fails. The default is || warn. The file test may \
+optionally have a "!' prepended to test for the opposite condition. If you do a \
+cd and then list some relative filenames, you may want to indent them slightly for \
+readability. If you supply your own die() or warn() message, you can use $file to \
+interpolate the filename. \
+\
+Filetests may be bunched: "-rwx" tests for all of -r, -w, and -x. Only the first failed \
+test of the bunch will produce a warning. \
+\
+The routine returns the number of warnings issued."
+
+HOMEPAGE = "http://search.cpan.org/~flora/File-CheckTree/"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c6fcacc5df80e037060300a7f4b93bf9"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/File-CheckTree-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "519c82aa7e5b7f752b4da14a6c8ad740"
+SRC_URI[sha256sum] = "fc99ab6bb5af4664832715974b5a19e328071dc9202ab72e5d5a594ebd46a729"
+
+S = "${WORKDIR}/File-CheckTree-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND = "native"