aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-08 20:17:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-09 09:16:00 -0800
commit7c337dbd59a6f7c9bd06131e5c0ad0de51e1d1e5 (patch)
tree428d4d24531cec0fd7364354797f36280b86adac /meta/recipes-kernel
parentc94152fee766297b355fec7f6d3d4d8ba7ae5f86 (diff)
downloadopenembedded-core-contrib-7c337dbd59a6f7c9bd06131e5c0ad0de51e1d1e5.tar.gz
dtc: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/dtc/dtc/make_install.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-kernel/dtc/dtc/make_install.patch b/meta/recipes-kernel/dtc/dtc/make_install.patch
index 1120617e7b..ccf17b38fd 100644
--- a/meta/recipes-kernel/dtc/dtc/make_install.patch
+++ b/meta/recipes-kernel/dtc/dtc/make_install.patch
@@ -2,11 +2,11 @@ Upstream-Status: Inappropriate [configuration]
Index: git/Makefile
===================================================================
---- git.orig/Makefile 2011-11-02 14:52:17.243104779 -0700
-+++ git/Makefile 2011-11-02 15:06:01.555104982 -0700
-@@ -161,8 +161,8 @@
- $(INSTALL) -d $(DESTDIR)$(BINDIR)
- $(INSTALL) $(BIN) $(SCRIPTS) $(DESTDIR)$(BINDIR)
+--- git.orig/Makefile
++++ git/Makefile
+@@ -168,8 +168,8 @@ install-bin: all $(SCRIPTS)
+ install-lib: all
+ @$(VECHO) INSTALL-LIB
$(INSTALL) -d $(DESTDIR)$(LIBDIR)
- $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
- ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
@@ -14,4 +14,4 @@ Index: git/Makefile
+ ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/$(notdir $(LIBFDT_lib))
ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/libfdt.$(SHAREDLIB_EXT)
$(INSTALL) -m 644 $(LIBFDT_archive) $(DESTDIR)$(LIBDIR)
- $(INSTALL) -d $(DESTDIR)$(INCLUDEDIR)
+