summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorAndrej Valek <andrej.valek@siemens.com>2020-11-29 08:49:20 +0100
committerSteve Sakoman <steve@sakoman.com>2020-12-10 04:11:06 -1000
commit09418489c550dc47c045c220e650afb198986676 (patch)
tree90e58e21a3e3bdbf06a014cea2df6a4ae86b2e9a /meta/recipes-kernel
parentd01a4149891637561b4bb1e9120eccb9619dadf4 (diff)
downloadopenembedded-core-contrib-09418489c550dc47c045c220e650afb198986676.tar.gz
kernel-dummy: fix executing unexpected tasks
- correctly save files into sstate - fix: ERROR: Task linux-dummy.do_fetch attempted to execute unexpectedly Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 16f6833ccd732de9f3db82ac5b0a18eea5298ceb) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-dummy.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-dummy.bb b/meta/recipes-kernel/linux/linux-dummy.bb
index 62cf6f5ea6..649fc04dd1 100644
--- a/meta/recipes-kernel/linux/linux-dummy.bb
+++ b/meta/recipes-kernel/linux/linux-dummy.bb
@@ -5,10 +5,12 @@ where you wish to build the kernel externally from the build system."
SECTION = "kernel"
LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
+LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
PROVIDES += "virtual/kernel"
+inherit deploy
+
PACKAGES_DYNAMIC += "^kernel-module-.*"
PACKAGES_DYNAMIC += "^kernel-image-.*"
PACKAGES_DYNAMIC += "^kernel-firmware-.*"