summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-07-20 17:08:52 +0100
committerSteve Sakoman <steve@sakoman.com>2022-07-28 05:32:25 -1000
commita4326da742c41f69c2d1d49cc8fdc2fda74aaa0d (patch)
treeccb9c7e83e94672ca459c1e23f9335acafe64adb /meta/recipes-kernel
parentaa6621dc1bc37d3e9a2aae3819619bf4e6c33bc4 (diff)
downloadopenembedded-core-contrib-a4326da742c41f69c2d1d49cc8fdc2fda74aaa0d.tar.gz
perf: fix reproduciblity in older releases of Linux
If you build perf from Linux 5.4 it still contains buildpaths (pointing to the sysroot's Python) as the existing fixes don't apply to the lines in that old release. Add further expressions to remove the final buildpaths. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 6783c1e295e5afafd73a02fd986ca8956a89dda7) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 603d3f9eee..95e7eae9fe 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -227,6 +227,9 @@ do_configure:prepend () {
# reproducible.
sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO))),g' \
${S}/tools/perf/Makefile.config
+ # The same line is in older releases, but looking explicitly for Python 2
+ sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON2)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON2))),g' \
+ ${S}/tools/perf/Makefile.config
# likewise with this substitution. Kernels with commit 18f2967418d031a39
# [perf tools: Use Python devtools for version autodetection rather than runtime]