aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-08-24 16:50:26 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-24 15:14:05 -0700
commitfc0220b59a15f8cff57c13fe7966d05f7386da71 (patch)
tree8d4a91b983cf7b7bd3b444dd7475baea65745c99 /meta/recipes-kernel
parentfaaa03c2a166e37a11edd52011799e6a8cff144d (diff)
downloadopenembedded-core-contrib-fc0220b59a15f8cff57c13fe7966d05f7386da71.tar.gz
linux-yocto-rt: update qemuppc support and streamline variables
Fixes [YOCTO #1391] Fixes [YOCTO #1389] qemuppc must have a dedicated branch for -rt support, since it has board specific patches that are not suitable for a common location. This fixes the boot by propagating some common fixes and by syncing to the latest meta-configuration. There are some variables that are now in linux-yocto.inc and need not be defined by the kernel recipe itself, so we can safely remove them with no impact on the build. CC: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
index c8a175dad8..61210debf1 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
@@ -9,14 +9,14 @@ KMACHINE_qemuppc = "qemu-ppc32"
KMACHINE_qemumips = "mti-malta32-be"
KBRANCH = "yocto/standard/preempt-rt/base"
-KMETA = meta
+KBRANCH_qemuppc = "yocto/standard/preempt-rt/qemu-ppc32"
LINUX_VERSION ?= "3.0"
LINUX_KERNEL_TYPE = "preempt-rt"
-LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
-SRCREV_machine = "7e1e5b6c8a13c615feb0d7b6d37988a094aae98f"
-SRCREV_meta = "7782fc673afd6a1c742409896ae787560d96fce8"
+SRCREV_machine ?= "67ce0924042a2faa12b71ac3e92175c789c32af6"
+SRCREV_machine_qemuppc ?= "839638f4efda0c70c6f491161ab2c042f5bc3e66"
+SRCREV_meta ?= "13dbce30d6a647228bf5a9483a9b9c2da1514f78"
PR = "r0"
PV = "${LINUX_VERSION}+git${SRCPV}"
@@ -30,14 +30,11 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0.git;protocol=git;nocheckou
COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)"
# Functionality flags
-KERNEL_REVISION_CHECKING ?= "t"
KERNEL_FEATURES=features/netfilter
KERNEL_FEATURES_append=" features/taskstats"
KERNEL_FEATURES_append_qemux86=" cfg/sound"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
-YOCTO_KERNEL_META_DATA=t
-
# extra tasks
addtask kernel_link_vmlinux after do_compile before do_install
addtask validate_branches before do_patch after do_kernel_checkout