aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-03-13 23:51:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-14 13:12:43 +0000
commite1f656492475fb65d1203afe0afeeec7e279a317 (patch)
tree7e36b2cc9a5088b251e67af7db60186157f4f429 /meta/recipes-kernel
parentfa15b1dfbf338969660a352deb870dfd5727bc47 (diff)
downloadopenembedded-core-contrib-e1f656492475fb65d1203afe0afeeec7e279a317.tar.gz
linux-yocto-tiny: add dependency on xz-native
The kernel configuration requires lzma to compress the kernel image (CONFIG_KERNEL_LZMA=y), so add a dependency on xz-native which provides it. Fixes [YOCTO #1728]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
index 5cad513a0f..a3a61673f2 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
@@ -1,6 +1,9 @@
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
+# We need lzma (as CONFIG_KERNEL_LZMA=y)
+DEPENDS += "xz-native"
+
#KMACHINE = "yocto/standard/tiny/base"
KMACHINE = "yocto/standard/base"
KBRANCH = "${KMACHINE}"
@@ -10,7 +13,7 @@ LINUX_VERSION ?= "3.0.23"
SRCREV_machine ?= "8fd24b3570ab995848e4123ef13bac64e2c924be"
SRCREV_meta ?= "e559129b4a6f39f68b75141096b2d516cf7a7f35"
-PR = "r2"
+PR = "r3"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta \