aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2012-09-19 10:06:55 +0300
committerSaul Wold <sgw@linux.intel.com>2012-09-20 22:21:14 -0700
commitcbb6431b3ee9128ea15c9ae0a19e7d2998ffc561 (patch)
tree151219aeac6c9bdb936ac387f27e8e366be9729e /meta/recipes-kernel
parenta35d03e2eb905de4eadc9c7df5b50bff1fb7f897 (diff)
downloadopenembedded-core-contrib-cbb6431b3ee9128ea15c9ae0a19e7d2998ffc561.tar.gz
qemux86-64: Support for KVM, paravirt and virtio added
KVM, paravirtualization and virtio drivers are now activated in runqemu using the kvm option flag for qemux86-64. Host CPU features are also exported to guest OS (Yocto Linux). Usage example: runqemu qemux86-64 core-image-x11 kvm Implements [YOCTO #2550]. Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
index 32ae02b512..06dd677fcb 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -15,7 +15,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckou
LINUX_VERSION ?= "3.4.10"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.3"
PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "meta"
@@ -28,4 +28,5 @@ KERNEL_FEATURES_append = " features/netfilter"
KERNEL_FEATURES_append_qemux86=" cfg/sound"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
KERNEL_FEATURES_append_qemux86=" cfg/paravirt_kvm"
+KERNEL_FEATURES_append_qemux86-64=" cfg/paravirt_kvm"
KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32", "" ,d)}"