aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-09-09 18:27:46 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-15 11:20:52 +0100
commita1ab7c5e03df97e630dfee470ff7959d3143bf41 (patch)
treebab99c72f06fa0290905bc6d82dfffcd08d1d39f /meta/recipes-kernel
parent07407baafb728c5ae1bb283f5b02a2ac773360bc (diff)
downloadopenembedded-core-contrib-a1ab7c5e03df97e630dfee470ff7959d3143bf41.tar.gz
linux-yocto: move common tasks to a common location
During the initial development of the linux-yocto recipes there were several additional tasks that needed to be run in any inheriting recipe. At that time, they didn't seem to fire if they were in the include file versus the recipes themselves. As it turns out, these tasks do work fine if placed in the linux-yocto.inc file, and the rest of the recipes can be simplified as a result. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb8
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb8
-rw-r--r--meta/recipes-kernel/linux/linux-yocto.inc5
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_2.6.37.bb13
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.0.bb8
5 files changed, 9 insertions, 33 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb b/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
index 0ca53ae436..d92a902a9a 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
@@ -17,9 +17,8 @@ SRCREV_machine_qemux86-64 = "3c84c45ad3c3592f9c7ff4076de9bee417cd322e"
SRCREV_machine = "439602eb6acd53d9beb8493710310214fc7bd749"
SRCREV_meta = "e1f85a470934a0cf6abde5d95533e74501822c6b"
-PR = "r2"
+PR = "r3"
PV = "${LINUX_VERSION}+git${SRCPV}"
-SRCREV_FORMAT = "meta_machine"
COMPATIBLE_MACHINE = "(qemux86|qemux86-64)"
@@ -34,11 +33,6 @@ python __anonymous () {
SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
# Functionality flags
-KERNEL_REVISION_CHECKING ?= "t"
KERNEL_FEATURES=features/netfilter
-# extra tasks
-addtask kernel_link_vmlinux after do_compile before do_install
-addtask validate_branches before do_patch after do_kernel_checkout
-
require recipes-kernel/linux/linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
index b296ef46f9..ebf60546c3 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
@@ -18,9 +18,8 @@ SRCREV_machine ?= "0b805cce57f61a244eb3b8fce460b14f1be442b3"
SRCREV_machine_qemuppc ?= "48207085609f2b73a54e3c1ef4139894eef627af"
SRCREV_meta ?= "3c9ebeed2598b74798a0c9247ef7c385e0cd96a7"
-PR = "r0"
+PR = "r1"
PV = "${LINUX_VERSION}+git${SRCPV}"
-SRCREV_FORMAT = "meta_machine"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
@@ -35,9 +34,4 @@ KERNEL_FEATURES_append=" features/taskstats"
KERNEL_FEATURES_append_qemux86=" cfg/sound"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
-# extra tasks
-addtask kernel_link_vmlinux after do_compile before do_install
-addtask validate_branches before do_patch after do_kernel_checkout
-addtask kernel_configcheck after do_configure before do_compile
-
require recipes-kernel/linux/linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto.inc b/meta/recipes-kernel/linux/linux-yocto.inc
index 11b77cefd1..09433fabe9 100644
--- a/meta/recipes-kernel/linux/linux-yocto.inc
+++ b/meta/recipes-kernel/linux/linux-yocto.inc
@@ -34,3 +34,8 @@ do_install_append(){
rm -rf ${STAGING_KERNEL_DIR}/${KMETA}
fi
}
+
+# extra tasks
+addtask kernel_link_vmlinux after do_compile before do_install
+addtask validate_branches before do_patch after do_kernel_checkout
+addtask kernel_configcheck after do_configure before do_compile
diff --git a/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
index 419913728a..34e563cffd 100644
--- a/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
@@ -9,10 +9,8 @@ KMACHINE_qemumips = "yocto/standard/mti-malta32-be"
KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs"
KBRANCH = ${KMACHINE}
-KMETA = meta
LINUX_VERSION ?= "2.6.37"
-LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
SRCREV_machine_qemuarm = "b3e53a090eaa23aa82e64fa0a563a93a2b4dbb5d"
SRCREV_machine_qemumips = "91f2eb4a3b447476b36aac8e6e198d08c98e0680"
@@ -22,26 +20,17 @@ SRCREV_machine_qemux86-64 = "af2bfbe5f757361b5b027a24d67a93bfdfaaf33c"
SRCREV_machine = "4ae8f8605c81c39b959948e23f7123294a5dfb3f"
SRCREV_meta = "aeea99683c7283f1f3320bf2ee7085ee252d4e7e"
-PR = "r20"
+PR = "r21"
PV = "${LINUX_VERSION}+git${SRCPV}"
-SRCREV_FORMAT = "meta_machine"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
# Functionality flags
-KERNEL_REVISION_CHECKING ?= "t"
KERNEL_FEATURES="features/netfilter"
KERNEL_FEATURES_append=" features/taskstats"
KERNEL_FEATURES_append_qemux86=" cfg/sound"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
-YOCTO_KERNEL_META_DATA=t
-
-# extra tasks
-addtask kernel_link_vmlinux after do_compile before do_install
-addtask validate_branches before do_patch after do_kernel_checkout
-addtask kernel_configcheck after do_configure before do_compile
-
require linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.0.bb b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
index f504b74dbd..b2965582bc 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
@@ -20,9 +20,8 @@ SRCREV_machine_qemux86-64 ?= "2b2d0954a6fd12b4bb7f02f019bc62633c8060a1"
SRCREV_machine ?= "6b2c7d65b844e686eae7d5cccb9b638887afe28e"
SRCREV_meta ?= "3c9ebeed2598b74798a0c9247ef7c385e0cd96a7"
-PR = "r1"
+PR = "r2"
PV = "${LINUX_VERSION}+git${SRCPV}"
-SRCREV_FORMAT = "meta_machine"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
@@ -34,9 +33,4 @@ KERNEL_FEATURES_append=" features/taskstats"
KERNEL_FEATURES_append_qemux86=" cfg/sound"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
-# extra tasks
-addtask kernel_link_vmlinux after do_compile before do_install
-addtask validate_branches before do_patch after do_kernel_checkout
-addtask kernel_configcheck after do_configure before do_compile
-
require linux-tools.inc