aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-02-26 22:53:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-26 22:51:41 +0000
commit960ee8076e860353a05eb2eb7f825a455c54698d (patch)
treeb4f479cd4f5a407464b2173026fe508b5997f8da /meta/recipes-kernel
parent30253358f5e76fb7b25be27198b4c125e0dbdf2c (diff)
downloadopenembedded-core-contrib-960ee8076e860353a05eb2eb7f825a455c54698d.tar.gz
More quoting fixes
* We have various variables which are either not quoted at all or are half quoted. This patch fixes the bad exmaples so everything is consistent. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/hello-mod/hello-mod_0.1.bb2
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb2
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-tools.inc4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb8
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb8
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto.inc6
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_2.6.37.bb10
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.0.bb10
-rw-r--r--meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb2
-rw-r--r--meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb2
12 files changed, 30 insertions, 30 deletions
diff --git a/meta/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta/recipes-kernel/hello-mod/hello-mod_0.1.bb
index bbd4984cd6..64a6ddad4c 100644
--- a/meta/recipes-kernel/hello-mod/hello-mod_0.1.bb
+++ b/meta/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
inherit module
-PR = r0
+PR = "r0"
PV = "0.1"
SRC_URI = "file://Makefile \
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index 14ec9e9333..b28402acfe 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d8
DEPENDS = "git-native guilt-native"
SRCREV = "91c2b184be90d6654996887203efdd7f1727a19a"
-PR = r12
+PR = "r12"
PV = "0.1+git${SRCPV}"
inherit native
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
index 1c709cbc23..734170f843 100644
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
@@ -17,7 +17,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout
# force this to empty to prevent installation failures, we aren't
# building a device tree as part of kern headers
-KERNEL_DEVICETREE=
+KERNEL_DEVICETREE = ""
set_arch() {
case ${TARGET_ARCH} in
diff --git a/meta/recipes-kernel/linux/linux-tools.inc b/meta/recipes-kernel/linux/linux-tools.inc
index b667421fb1..3b03c05167 100644
--- a/meta/recipes-kernel/linux/linux-tools.inc
+++ b/meta/recipes-kernel/linux/linux-tools.inc
@@ -29,8 +29,8 @@ fakeroot do_install_perf () {
addtask compile_perf after do_compile before do_install
addtask install_perf after do_install before do_package
-do_compile_perf[umask] = 022
-do_install_perf[umask] = 022
+do_compile_perf[umask] = "022"
+do_install_perf[umask] = "022"
PERFDEPENDS = "virtual/${MLPREFIX}libc:do_populate_sysroot ${MLPREFIX}elfutils:do_populate_sysroot ${MLPREFIX}binutils:do_populate_sysroot"
PERFDEPENDS_libc-uclibc = ""
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
index b947a48fac..3d4a1d0264 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
@@ -29,9 +29,9 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0.git;protocol=git;nocheckou
COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)"
# Functionality flags
-KERNEL_FEATURES=features/netfilter
-KERNEL_FEATURES_append=" features/taskstats"
-KERNEL_FEATURES_append_qemux86=" cfg/sound"
-KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
+KERNEL_FEATURES = "features/netfilter"
+KERNEL_FEATURES_append = " features/taskstats"
+KERNEL_FEATURES_append_qemux86 = " cfg/sound"
+KERNEL_FEATURES_append_qemux86-64 = " cfg/sound"
require recipes-kernel/linux/linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
index 9b0c1bf98e..329527fb50 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
@@ -29,9 +29,9 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2.git;protocol=git;nocheckou
COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)"
# Functionality flags
-KERNEL_FEATURES=features/netfilter
-KERNEL_FEATURES_append=" features/taskstats"
-KERNEL_FEATURES_append_qemux86=" cfg/sound"
-KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
+KERNEL_FEATURES = "features/netfilter"
+KERNEL_FEATURES_append = " features/taskstats"
+KERNEL_FEATURES_append_qemux86 = " cfg/sound"
+KERNEL_FEATURES_append_qemux86-64 = " cfg/sound"
require recipes-kernel/linux/linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
index c5855a3576..061476c6e1 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
@@ -3,7 +3,7 @@ require recipes-kernel/linux/linux-yocto.inc
#KMACHINE = "yocto/standard/tiny/base"
KMACHINE = "yocto/standard/base"
-KBRANCH = ${KMACHINE}
+KBRANCH = "${KMACHINE}"
LINUX_VERSION ?= "3.0.12"
@@ -33,4 +33,4 @@ SRC_URI_append_qemux86 = " file://defconfig file://ata.cfg file://e1000.cfg"
COMPATIBLE_MACHINE = "(qemux86)"
# Functionality flags
-KERNEL_FEATURES=""
+KERNEL_FEATURES = ""
diff --git a/meta/recipes-kernel/linux/linux-yocto.inc b/meta/recipes-kernel/linux/linux-yocto.inc
index 09433fabe9..2b61b7e2cc 100644
--- a/meta/recipes-kernel/linux/linux-yocto.inc
+++ b/meta/recipes-kernel/linux/linux-yocto.inc
@@ -10,14 +10,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
# KMACHINE = "UNDEFINED"
# Set this to 'preempt_rt' in the local.conf if you want a real time kernel
-LINUX_KERNEL_TYPE ?= standard
+LINUX_KERNEL_TYPE ?= "standard"
-KMETA ?= meta
+KMETA ?= "meta"
SRCREV_FORMAT ?= "meta_machine"
LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
KERNEL_REVISION_CHECKING ?= "t"
-YOCTO_KERNEL_META_DATA ?= t
+YOCTO_KERNEL_META_DATA ?= "t"
do_patch[depends] = "kern-tools-native:do_populate_sysroot"
diff --git a/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
index ce7139352c..27c7558cb2 100644
--- a/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
@@ -8,7 +8,7 @@ KMACHINE_qemuppc = "yocto/standard/qemu-ppc32"
KMACHINE_qemumips = "yocto/standard/mti-malta32-be"
KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs"
-KBRANCH = ${KMACHINE}
+KBRANCH = "${KMACHINE}"
LINUX_VERSION ?= "2.6.37"
@@ -28,9 +28,9 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout
COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
# Functionality flags
-KERNEL_FEATURES="features/netfilter"
-KERNEL_FEATURES_append=" features/taskstats"
-KERNEL_FEATURES_append_qemux86=" cfg/sound"
-KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
+KERNEL_FEATURES = "features/netfilter"
+KERNEL_FEATURES_append = " features/taskstats"
+KERNEL_FEATURES_append_qemux86 = " cfg/sound"
+KERNEL_FEATURES_append_qemux86-64 = " cfg/sound"
require linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.0.bb b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
index 44a9fe4402..d52e93adaa 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
@@ -8,7 +8,7 @@ KMACHINE_qemuppc = "yocto/standard/qemu-ppc32"
KMACHINE_qemumips = "yocto/standard/mti-malta32-be"
KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs"
-KBRANCH = ${KMACHINE}
+KBRANCH = "${KMACHINE}"
LINUX_VERSION ?= "3.0.18"
@@ -28,9 +28,9 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;nocheckout=1;
COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
# Functionality flags
-KERNEL_FEATURES="features/netfilter"
-KERNEL_FEATURES_append=" features/taskstats"
-KERNEL_FEATURES_append_qemux86=" cfg/sound"
-KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
+KERNEL_FEATURES = "features/netfilter"
+KERNEL_FEATURES_append = " features/taskstats"
+KERNEL_FEATURES_append_qemux86 = " cfg/sound"
+KERNEL_FEATURES_append_qemux86-64 = " cfg/sound"
require linux-tools.inc
diff --git a/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb b/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb
index 5d34c41a34..4d2f62be3d 100644
--- a/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb
+++ b/meta/recipes-kernel/lttng-2.0/lttng-modules_2.0.pre11.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1eb086682a7c65a45acd9bcdf6877b3e \
file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
-DEPENDS = virtual/kernel
+DEPENDS = "virtual/kernel"
inherit module
diff --git a/meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb b/meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb
index 7fa674853b..b328e6bac8 100644
--- a/meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap-uprobes_git.bb
@@ -7,7 +7,7 @@ DEPENDS = "systemtap virtual/kernel"
PR = "r0"
# On systems without CONFIG_UTRACE, this package is empty.
-ALLOW_EMPTY_${PN} = 1
+ALLOW_EMPTY_${PN} = "1"
inherit module-base gettext