aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-22 10:59:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-23 11:15:49 +0100
commit32ba716e71fb7a16f13c83ab6c8cc51de56b3be2 (patch)
treed5d4e01aff6407a46e2bb942445210c8245bc93b /meta/recipes-kernel
parentc985b02130658dd64581ecf14b16e2c70d1d8db5 (diff)
downloadopenembedded-core-contrib-32ba716e71fb7a16f13c83ab6c8cc51de56b3be2.tar.gz
linux-yocto: Remove parens from COMPATIBLE_MACHINE regexp
This helps in appending to this regexp from bbappends coming from other layers who want to leverage linux-yocto with minimum tweaks by using a standard prefefined machine from linux-yocto Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.0.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.2.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.0.bb b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
index f5e812ec84..4d19664f15 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
@@ -26,7 +26,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;bareclone=1;b
SRC_URI += "file://noslang.patch"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
+COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
# Functionality flags
KERNEL_FEATURES = "features/netfilter"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.2.bb b/meta/recipes-kernel/linux/linux-yocto_3.2.bb
index b2542516d1..c3fb2521aa 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.2.bb
@@ -26,7 +26,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;bareclone=1;b
SRC_URI += "file://noslang.patch"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
+COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
# Functionality flags
KERNEL_FEATURES="features/netfilter"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
index 8ac240275e..691d78968a 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -22,7 +22,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "meta"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
+COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
# Functionality flags
KERNEL_REVISION_CHECKING=""