aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-10-10 14:11:07 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-11 22:56:28 +0100
commit149f2262135ca87608783a8801c9c2d978d8c8ef (patch)
tree64e227daee6dca157702d54b8914a2508e9471ac /meta/recipes-kernel
parentb5f744c5d6fea4e5f33545d1dbf40d2f964cb786 (diff)
downloadopenembedded-core-contrib-149f2262135ca87608783a8801c9c2d978d8c8ef.tar.gz
routerstationpro: create machine conf and compatibility
BUGID: 422 Add the machine configuration and kernel infrastructure for building the routerstation pro BSP. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-wrs_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-wrs_git.bb b/meta/recipes-kernel/linux/linux-wrs_git.bb
index f6b0aead55..f99be25c75 100644
--- a/meta/recipes-kernel/linux/linux-wrs_git.bb
+++ b/meta/recipes-kernel/linux/linux-wrs_git.bb
@@ -26,12 +26,13 @@ WRMACHINE_qemuppc = "qemu_ppc32"
WRMACHINE_qemumips = "mti_malta32_be"
WRMACHINE_qemuarm = "arm_versatile_926ejs"
WRMACHINE_atom-pc = "common_pc"
+WRMACHINE_routerstationpro = "routerstationpro"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc)"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro)"
LINUX_VERSION = "v2.6.34"
LINUX_VERSION_EXTENSION = "-wr-${LINUX_KERNEL_TYPE}"
-PR = "r7"
+PR = "r8"
S = "${WORKDIR}/linux"
B = "${WORKDIR}/linux-${WRMACHINE}-${LINUX_KERNEL_TYPE}-build"
@@ -166,6 +167,9 @@ do_wrlinux_configcheck() {
}
do_wrlinux_link_vmlinux() {
+ if [ ! -d "${B}/arch/${ARCH}/boot" ]; then
+ mkdir ${B}/arch/${ARCH}/boot
+ fi
cd ${B}/arch/${ARCH}/boot
ln -sf ../../../vmlinux
}