summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-12-26 16:50:02 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-30 14:01:00 +0000
commitcb940d8af359fa370254bd4c2b36ba26708bb54b (patch)
tree407994ee74ce788cbdad5b9eec46a7c12c19abe5 /meta/recipes-kernel
parent53988b6389ce618d4cff52bd09ae91108beca354 (diff)
downloadopenembedded-core-contrib-cb940d8af359fa370254bd4c2b36ba26708bb54b.tar.gz
kernel-devsrc: fix 32bit ARM devsrc builds
As a follow up to commit: 0fc66a0b64953 [kernel: provide module.lds for out of tree builds in v5.10+], we must not only copy module.lds from its new location, we have to not error when it isn't found in the old location. With this tweak, we have coverage on all supported arches for the new location of module.lds, and backwards compatibility through kernel versions. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 8a900ed182..dadeade3aa 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -186,7 +186,7 @@ do_install() {
cp -a --parents $SYSCALL_TOOLS $kerneldir/build/
fi
- cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/
+ cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/ 2>/dev/null || :
fi
if [ -d arch/${ARCH}/include ]; then