summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorVictor Kamensky <kamensky@cisco.com>2018-10-25 19:59:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-28 08:31:49 +0000
commit03e01c26a297642dbe4b0e1c7cf2cbe3c225140e (patch)
tree8e8e49e0e0e07f7ae17b7f7423f633d6941c942a /meta/recipes-kernel
parent5c7d9abcd611d23d4340f9a0aee2564f72158a0b (diff)
downloadopenembedded-core-contrib-03e01c26a297642dbe4b0e1c7cf2cbe3c225140e.tar.gz
systemtap: move systemtap-exporter into separate package
stap-exporter runs a set of systemtap scripts and relays their procfs outputs to remote HTTP clients on demand. systemtap-exporter is not supposed to run in untrusted environment. It starts HTTP server on some port. It does not look safe enough to be included by default along with the rest of systemtap. Move systemtap-exporter, its systemd unit, configuration files and examples scripts into separate package. So if one needs it and understand its implication, he/she can include it explicitely. Signed-off-by: Victor Kamensky <kamensky@cisco.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 904ecdd106..6ee3e1c0f7 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -27,7 +27,16 @@ PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,
inherit autotools gettext pkgconfig distutils3-base systemd
-SYSTEMD_SERVICE_${PN} = "stap-exporter.service"
+PACKAGES =+ "${PN}-exporter"
+
+FILES_${PN}-exporter = "${sysconfdir}/stap-exporter/* \
+ ${sysconfdir}/sysconfig/stap-exporter \
+ ${systemd_unitdir}/system/stap-exporter.service \
+ ${sbindir}/stap-exporter"
+
+RDEPENDS_${PN}-exporter = "${PN} python3-core python3-netclient"
+
+SYSTEMD_SERVICE_${PN}-exporter = "stap-exporter.service"
do_configure_prepend () {
# Improve reproducibility for c++ object files