summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2012-12-12 12:08:37 +0500
committerSaul Wold <sgw@linux.intel.com>2012-12-14 15:17:20 -0800
commitdce7918a818bf86fcc11f561af3eacaf281403d4 (patch)
treeb77c89170d586f2746246d12a43c133027338064 /meta/recipes-kernel
parentaa591ecb1aac1c0308c05dbac81bc056869a2c3e (diff)
downloadopenembedded-core-contrib-dce7918a818bf86fcc11f561af3eacaf281403d4.tar.gz
perf: kill -Werror
this fails to build using a recent sourcery toolchain due to unused-but-set-variable Signed-off-by: Christopher Larson <chris_larson@mentor.com> the patch was imported from meta-mentor layer on yoctoproject git server http://git.yoctoproject.org/cgit/cgit.cgi/meta-mentor as of commit ids 82e96b3baa1c64d03412871fce56d496a338f167 and ae325d011bd50501fe677c8b37295ae83030c526 Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf_3.4.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf_3.4.bb b/meta/recipes-kernel/perf/perf_3.4.bb
index b09436231f..4e6d03d005 100644
--- a/meta/recipes-kernel/perf/perf_3.4.bb
+++ b/meta/recipes-kernel/perf/perf_3.4.bb
@@ -9,7 +9,7 @@ as well."
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-PR = "r5"
+PR = "r6"
require perf.inc
@@ -79,6 +79,10 @@ do_install() {
fi
}
+do_configure_prepend () {
+ sed -i 's,-Werror ,,' ${S}/tools/perf/Makefile
+}
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
FILES_${PN} += "${libexecdir}/perf-core"