summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2012-12-12 16:26:12 +0500
committerSaul Wold <sgw@linux.intel.com>2012-12-14 15:17:20 -0800
commitaccbcea94091800a90df0f5141990c110ff35ee5 (patch)
tree956e624f08bc2949a6696542c58f5e79374d139a /meta/recipes-kernel
parent373371432b72cb19600a45e741afdfcb9662ecfb (diff)
downloadopenembedded-core-contrib-accbcea94091800a90df0f5141990c110ff35ee5.tar.gz
iperf: pass in target path vars
Signed-off-by: Christopher Larson <chris_larson@mentor.com> the patch was imported from meta-mentor layer on yoctoproject git server http://git.yoctoproject.org/cgit/cgit.cgi/meta-mentor as of commit id 71748b54694f4ffe2d598da71f641969df1417c0 slightly modified the patch to apply it on .bb file instead of .bbappend Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf_3.4.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf_3.4.bb b/meta/recipes-kernel/perf/perf_3.4.bb
index 8d1b2324b3..e89a7c3ba4 100644
--- a/meta/recipes-kernel/perf/perf_3.4.bb
+++ b/meta/recipes-kernel/perf/perf_3.4.bb
@@ -73,6 +73,17 @@ EXTRA_OEMAKE = \
EXTRA_OEMAKE += "\
'CFLAGS=${CFLAGS}' \
'LDFLAGS=${LDFLAGS} -lpthread -lrt -lelf -lm -lbfd' \
+ \
+ 'prefix=${prefix}' \
+ 'bindir=${bindir}' \
+ 'sharedir=${datadir}' \
+ 'sysconfdir=${sysconfdir}' \
+ 'perfexecdir=${libexecdir}/perf-core' \
+ \
+ 'ETC_PERFCONFIG=${@oe.path.relative(prefix, sysconfdir)}' \
+ 'sharedir=${@oe.path.relative(prefix, datadir)}' \
+ 'mandir=${@oe.path.relative(prefix, mandir)}' \
+ 'infodir=${@oe.path.relative(prefix, infodir)}' \
"
do_compile() {