summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2019-02-04 16:39:01 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-06 08:29:02 +0000
commit7b4d77d7f909c0ae27553fd9c480f069f12e468f (patch)
tree19da41ee19b81f83be81a8766d3610a744e15023 /meta/recipes-kernel
parent6ab11ac25bb987642d5ca1a07f4bd5f30c66c9c5 (diff)
downloadopenembedded-core-contrib-7b4d77d7f909c0ae27553fd9c480f069f12e468f.tar.gz
kernel-devsrc: restore compatibility with kernel < v4.10
The kernel commit that added the syscall table generation tools for ARM platform (ARM: convert to generated system call tables) wasn't merged until kernel release v4.10. Current assumption in kernel-devsrc recipe is that these syscall scripts exist, which breaks the build for external board layers that are still using 4.9.x kernels: cp: cannot stat ‘arch/arm/tools/syscall*’: No such file or directory so only try to install the scripts when they actually exist. Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 87347fa969..8fc0ffdbb3 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -157,7 +157,12 @@ do_install() {
# include a few files for 'make prepare'
cp -a --parents arch/arm/tools/gen-mach-types $kerneldir/build/
cp -a --parents arch/arm/tools/mach-types $kerneldir/build/
- cp -a --parents arch/arm/tools/syscall* $kerneldir/build/
+
+ # ARM syscall table tools only exist for kernels v4.10 or later
+ SYSCALL_TOOLS=$(find arch/arm/tools -name "syscall*")
+ if [ -n "$SYSCALL_TOOLS" ] ; then
+ cp -a --parents $SYSCALL_TOOLS $kerneldir/build/
+ fi
cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/
fi