summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2012-12-12 16:26:11 +0500
committerSaul Wold <sgw@linux.intel.com>2012-12-14 15:17:20 -0800
commit373371432b72cb19600a45e741afdfcb9662ecfb (patch)
tree10867d7714749c403e080ca465c64db37b9b9558 /meta/recipes-kernel
parentdce7918a818bf86fcc11f561af3eacaf281403d4 (diff)
downloadopenembedded-core-contrib-373371432b72cb19600a45e741afdfcb9662ecfb.tar.gz
perf: pass CFLAGS and LDFLAGS
Signed-off-by: Christopher Larson <chris_larson@mentor.com> the patch was imported from meta-mentor layer on yoctoproject git server http://git.yoctoproject.org/cgit/cgit.cgi/meta-mentor as of commit id 9d698004137c1a888d40d6a4808d94afa22387e7 Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf_3.4.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf_3.4.bb b/meta/recipes-kernel/perf/perf_3.4.bb
index 4e6d03d005..8d1b2324b3 100644
--- a/meta/recipes-kernel/perf/perf_3.4.bb
+++ b/meta/recipes-kernel/perf/perf_3.4.bb
@@ -9,7 +9,7 @@ as well."
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-PR = "r6"
+PR = "r8"
require perf.inc
@@ -67,6 +67,14 @@ EXTRA_OEMAKE = \
NO_GTK2=1 ${TUI_DEFINES} NO_DWARF=1 ${SCRIPTING_DEFINES} \
'
+# We already pass the correct arguments to our compiler for the CFLAGS (if we
+# don't override it, it'll add -m32/-m64 itself). For LDFLAGS, it was failing
+# to find bfd symbols.
+EXTRA_OEMAKE += "\
+ 'CFLAGS=${CFLAGS}' \
+ 'LDFLAGS=${LDFLAGS} -lpthread -lrt -lelf -lm -lbfd' \
+"
+
do_compile() {
oe_runmake all
}