summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorJack Mitchell <jack.mitchell@dbbroadcast.co.uk>2012-10-29 09:28:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-02 16:15:28 +0000
commit1b41a4660d0dd8f1863bb94d08562927cc108ee1 (patch)
tree8872198114d833695fe997f77d33cb8af327bce4 /meta/recipes-kernel
parent4395691a44b198ba0b9a969cbade669e8de07a4f (diff)
downloadopenembedded-core-contrib-1b41a4660d0dd8f1863bb94d08562927cc108ee1.tar.gz
latencytop: disable GTK and remove gtk+ dependacy
When DISTRO_FEATURES does not contain x11, disable GTK GUI and also don't add gtk+ to the DEPENDS Signed-off-by: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/latencytop/latencytop-0.5/latencytop-makefile.patch13
-rw-r--r--meta/recipes-kernel/latencytop/latencytop_0.5.bb8
2 files changed, 12 insertions, 9 deletions
diff --git a/meta/recipes-kernel/latencytop/latencytop-0.5/latencytop-makefile.patch b/meta/recipes-kernel/latencytop/latencytop-0.5/latencytop-makefile.patch
index 59a0b1f6dc..596450c5b9 100644
--- a/meta/recipes-kernel/latencytop/latencytop-0.5/latencytop-makefile.patch
+++ b/meta/recipes-kernel/latencytop/latencytop-0.5/latencytop-makefile.patch
@@ -1,8 +1,9 @@
-Upstream-Status: Inappropriate [configuration]
-
---- a/Makefile 2010-07-20 18:51:32.000000000 +0800
-+++ b/Makefile 2010-07-20 18:54:54.000000000 +0800
-@@ -4,7 +4,8 @@
+--- a/Makefile 2010-07-20 18:51:32.000000000 +0800
++++ b/Makefile 2010-07-20 18:54:54.000000000 +0800
+@@ -1,10 +1,8 @@
+-# FIXME: Use autoconf ?
+-HAS_GTK_GUI = 1
+-
DESTDIR =
SBINDIR = /usr/sbin
XCFLAGS = -W -g `pkg-config --cflags glib-2.0` -D_FORTIFY_SOURCE=2 -Wno-sign-compare
@@ -12,7 +13,7 @@ Upstream-Status: Inappropriate [configuration]
OBJS= latencytop.o text_display.o translate.o fsync.o
-@@ -26,16 +27,17 @@
+@@ -26,16 +24,17 @@
# We write explicity this "implicit rule"
%.o : %.c
diff --git a/meta/recipes-kernel/latencytop/latencytop_0.5.bb b/meta/recipes-kernel/latencytop/latencytop_0.5.bb
index 15f3667076..3e35bf910d 100644
--- a/meta/recipes-kernel/latencytop/latencytop_0.5.bb
+++ b/meta/recipes-kernel/latencytop/latencytop_0.5.bb
@@ -5,9 +5,9 @@ BUGTRACKER = "n/a"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://latencytop.c;endline=23;md5=ee9ea9b1415356e5734adad4a87dc7fa"
-DEPENDS = "virtual/libintl ncurses glib-2.0 gtk+"
+DEPENDS = "virtual/libintl ncurses glib-2.0 ${@base_contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.latencytop.org/download/latencytop-${PV}.tar.gz \
file://latencytop-makefile.patch"
@@ -15,8 +15,10 @@ SRC_URI = "http://www.latencytop.org/download/latencytop-${PV}.tar.gz \
SRC_URI[md5sum] = "73bb3371c6ee0b0e68e25289027e865c"
SRC_URI[sha256sum] = "9e7f72fbea7bd918e71212a1eabaad8488d2c602205d2e3c95d62cd57e9203ef"
+EXTRA_OEMAKE_X = "${@base_contains('DISTRO_FEATURES', 'x11', 'HAS_GTK_GUI=1', '', d)}"
+
CFLAGS += "${LDFLAGS}"
do_install() {
- oe_runmake install DESTDIR=${D}
+ oe_runmake install DESTDIR=${D} ${EXTRA_OEMAKE_X}
}